[PATCH 22/25] gnu: go-honnef-co-go-tools: Update to 0.3.3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:45
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-23-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-honnef-co-go-tools): Update to 0.3.3.
---
gnu/packages/golang.scm | 31 +++++++++++++++----------------
1 file changed, 15 insertions(+), 16 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 660deceec5..97f1753f42 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10008,27 +10008,26 @@ (define-public go-github-com-kisielk-gotool
(define-public go-honnef-co-go-tools
(package
(name "go-honnef-co-go-tools")
- (version "0.1.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dominikh/go-tools")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "17li8jbw3cpn59kpcl3j3r2an4wkx3fc81xn0j4xgbjpkxh9493n"))))
+ (version "0.3.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dominikh/go-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "099z04v7vvwwglnps315s9fmal68xvzlc1g8m26iqi980grbwn32"))))
(build-system go-build-system)
(arguments
`(#:import-path "honnef.co/go/tools"
#:tests? #f
;; Source-only package
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
- (propagated-inputs
- (list go-golang-org-x-tools go-github-com-kisielk-gotool
- go-github-com-burntsushi-toml))
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs (list go-golang-org-x-exp go-golang-org-x-tools
+ go-golang-org-x-mod go-github-com-kisielk-gotool
+ go-github-com-burntsushi-toml))
(home-page "https://honnef.co/go/tools")
(synopsis "Staticcheck advanced Go linter")
(description
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60920] [PATCH 22/25] gnu: go-honnef-co-go-tools: Update to 0.3.3.
CQBV1ODZX4LL.DBW3M5XNPRZH@guix-framework
* gnu/packages/golang.scm (go-honnef-co-go-tools): Update to 0.3.3.

Toggle quote (9 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -10008,27 +10008,26 @@ (define-public go-github-com-kisielk-gotool

> + (propagated-inputs (list go-golang-org-x-exp go-golang-org-x-tools
> + go-golang-org-x-mod go-github-com-kisielk-gotool
> + go-github-com-burntsushi-toml))

Add newlines between the inputs.

Toggle quote (2 lines)
> (synopsis "Staticcheck advanced Go linter")

Please change this to:

(synopsis "Static linter for Go code")

Toggle quote (2 lines)
> (description

I don't know what the description here is, but could you try to improve it
too if necessary?

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhif8ACgkQ7ImHg/nq
I22iLQwAj9VZoSe6k2eT8Xvqlh/KtM+ZN3kawtFxiGMl+zWin2Qc6bRQhgehpYtK
L1R0ETuh/BPgJE2QNMFpLRxvBFMfJBsbe8qpb7vGF9SSApiKmwKre/+dlm/GTFC1
wSHWdSMPMrdNDk+8wkB2+Hmv68PzmEhbhkUQJ/KUxF3znGtv/2YuMAKj9ibKFtP8
X0krWmYdcfnJ0zU32TNCR92rZ88YyTrAiyYgoWThvYe9XMx3PNAl4zl/TEm/wua7
fQlFB36NsYFNukaJUpeWSmyp8twsshWEysbEt8dAwjskO5bgIgBRqpYxlnm+4zkK
1tbO7dT2eJ0zyQYjdms6D/hEwzL9iSbsqru6VZF1IjTekXk3FQDzWN8WrAiJoYnG
h2zPv8LeEo1x3+JAObq0BHixA5RuRhjmjR7zpB9lX7AGgmxLu/aVJXXhepM5iYF0
GxoIG7vFOZbsYD69mOEAB4u12FJbGSFmycL13PZxN/7zhFmjSIunvgcSAkxJ9Igb
FJJXVzln
=y42i
-----END PGP SIGNATURE-----


?