[PATCH 14/25] gnu: Add misspell.

  • Done
  • quality assurance status badge
Details
4 participants
  • Katherine Cox-Buday
  • Christopher Baines
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-15-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (misspell): New variable.
---
gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2b778ac49e..b84fe59503 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4821,6 +4821,35 @@ (define-public go-gitlab-com-ambrevar-damerau
similar word.")
(license license:expat))))
+(define-public misspell
+ (package
+ (name "misspell")
+ (version "0.3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/client9/misspell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vwf33wsc4la25zk9nylpbp9px3svlmldkm0bha4hp56jws4q9cs"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/client9/misspell"
+ #:phases (modify-phases %standard-phases
+ (replace 'build
+ (lambda arguments
+ (apply (assoc-ref %standard-phases
+ 'build)
+ `(,@arguments #:import-path
+ "github.com/client9/misspell/cmd/misspell")))))))
+ (home-page "https://github.com/client9/misspell")
+ (synopsis "Install")
+ (description
+ "Package misspell corrects commonly misspelled English words in source files.")
+ (license license:expat)))
+
(define-public go-github-com-stevedonovan-luar
(let ((commit "22d247e5366095f491cd83edf779ee99a78f5ead")
(revision "0"))
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60912] [PATCH 14/25] gnu: Add misspell.
CQBU7MX2V1TK.HYU20AL5Y812@guix-framework
* gnu/packages/golang.scm (misspell): New variable.

Toggle quote (15 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -4821,6 +4821,35 @@ (define-public go-gitlab-com-ambrevar-damerau

> + (arguments
> + '(#:import-path "github.com/client9/misspell"
> + #:phases (modify-phases %standard-phases
> + (replace 'build
> + (lambda arguments
> + (apply (assoc-ref %standard-phases
> + 'build)
> + `(,@arguments #:import-path
> + "github.com/client9/misspell/cmd/misspell")))))))

Same comment on this arguments field as the last two.

Toggle quote (2 lines)
> + (synopsis "Install")

Um... :)

Toggle quote (3 lines)
> + (description
> + "Package misspell corrects commonly misspelled English words in source files.")

s/Package misspell/This package/

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhgM0ACgkQ7ImHg/nq
I21JjAv/QL1vcDjcJYrbdI2HYa8DHpcs0UzbjxxKudH9Sr8Wix9bEfyF/CEca2m5
by0rNFIQZxVv3HcTVJP+I7XMGViTVZbDZCDm1Q8KBZICxrxVO5JYuaA1yfRzfmLo
rIprH7E+wnSOd0rnMKpj5+Kayf5mo2XiVyDWOJ5/SGlnf4uWQdbf4sN++4pnXYlV
30ZNAluoE0weZpwn6dafcLz+qFVO6XmX9piN2nz82PU+Y3bLXeD1f9rsIEXXp2PY
M02yySKs3bueyvHQEp5yOQMPOKxv85ZoGsagr7p4AN8I8yCRxLqgFEcELmCXSDiH
60qCrdFz7e1dwrzR/P73FJCf7gUHDlYruCUS2vhQYqkbNEbjf1LeOAezerHnmZlQ
s1nx35gDLZoOHtQCq6sRzhIdWfIihBfx0EUJrGca0JFcOw5alvbZzaSn/zBDDPmD
9WdbGn3hK9R7BNDJg/3RbNfHtdNgbZWqYB4K4C/KsL5YUyBY0hBL60ea4ZYtZP7/
3TuiosOx
=0VbW
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 6 Feb 2023 23:36
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
87k00ucrzr.fsf@cbaines.net
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

Toggle quote (5 lines)
> * gnu/packages/golang.scm (misspell): New variable.
> ---
> gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)

...

Toggle quote (4 lines)
> + (synopsis "Install")
> + (description
> + "Package misspell corrects commonly misspelled English words in source files.")

I've changed this to:

(synopsis "Correct commonly misspelled English words in source files")
(description
"misspell assists with correcting commonly misspelled English words in
source files. A neutral variety of English is used by default, but a US or UK
locale can be selected.")
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmPhiEhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xeq3A/+IhinjnJjhWEaMVo+YTDwkPl31gj8qhIJ
UnY98fSml++yoGcgnYO9Aiq82DePEYySCCRgJ+65rQAp9OxZGSrWA7p84nvdrkiu
C4KEqIvFr0eTLnaUi+uHjsh5ILnG7qCX/Zq6I5RsB2390V2M/2F1m7yonPXio5zP
6mb1THsvi4KRggaBfNpb3tq+rTWa7fAp5WmCkOhqJznZrGw6Fsb+3Aw04WJzlYmo
vjy7KQZmvQ0Ex6A54lKStZVsGgLFuRoa4LU/BKATjZRS1W6/0caHgG3w3aktQJj0
p12JfAZRC1pkQpInUFCUJItsiJCgb+PheQAeJi5+EO2nQ+MSiK0MUldqkGJ/yVLk
A/W7rOw+xZLLtwR91mU7UWpMONb1GbnB0R7YNPhyyXVdcO0fl98kvV2MtJ+vWbFS
POnDMJj4l8TQubfXyLYY49XY9rnsCZ6xzR0OuMuaoMWdlFBx89Np0uWUXXTDQiDs
VdXi3G1dD5M6yqt32LzQHaPE/nJ5Gt7PnEiUvawkJwUUwr8n33No25lQbHdT9wZf
CqQaem7KOwLHUCbVihP+oqge/GuhCWL3DyQ9aZdzvGWdma2YpnizHvytpbY7ffOF
3Bl4YMJWopQnm4Hc+ef5TAmz0gLq6x9EmgOb82/vBP+lrr7mJuKtAGOAafuW+WW+
PKGycgsgteM=
=6rnG
-----END PGP SIGNATURE-----

K
K
Katherine Cox-Buday wrote on 7 Feb 2023 18:53
(name . Christopher Baines)(address . mail@cbaines.net)(address . 60912@debbugs.gnu.org)
87y1p9wee1.fsf@gmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (13 lines)
> Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
>
>> * gnu/packages/golang.scm (misspell): New variable.
>> ---
>> gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
>> 1 file changed, 29 insertions(+)
>
> ...
>
>> + (synopsis "Install")
>> + (description
>> + "Package misspell corrects commonly misspelled English words in source files.")

Oh jees! Sorry about that! My best guess is that I was typing in another
window, nudged the mouse, and then `guix style` capitalized it.

Toggle quote (8 lines)
> I've changed this to:
>
> (synopsis "Correct commonly misspelled English words in source files")
> (description
> "misspell assists with correcting commonly misspelled English words in
> source files. A neutral variety of English is used by default, but a US or UK
> locale can be selected.")

Thank you!

--
Katherine
?