[PATCH 17/25] gnu: Add unparam.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:45
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-18-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (unparam): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ced6438581..d980026a70 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9803,6 +9803,31 @@ (define-public go-go-uber-org-multierr
"@code{multierr} allows combining one or more Go errors together.")
(license license:expat)))
+(define-public unparam
+ (package
+ (name "unparam")
+ (version "0.0.0-20221223090309-7455f1af531d")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvdan/unparam")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wynf0b32azxljncw5fh9bwkxpdflvf9q1z16wyj432566yjh12c"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "mvdan.cc/unparam"
+ #:go ,go-1.19))
+ (inputs (list go-golang-org-x-sys go-golang-org-x-mod
+ go-github-com-pkg-diff go-golang-org-x-tools
+ go-github-com-rogpeppe-go-internal))
+ (home-page "https://mvdan.cc/unparam/")
+ (synopsis "Find unused parameters in Go")
+ (description "Reports unused function parameters and results in Go code.")
+ (license license:bsd-3)))
+
(define-public xurls
(package
(name "xurls")
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60916] [PATCH 17/25] gnu: Add unparam.
CQBUVRVCYCE5.2ZSZXYJ1MHNQT@guix-framework
* gnu/packages/golang.scm (unparam): New variable.

Toggle quote (7 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -9803,6 +9803,31 @@ (define-public go-go-uber-org-multierr

> + (version "0.0.0-20221223090309-7455f1af531d")

Please use git-version instead.

Toggle quote (2 lines)
> + (synopsis "Find unused parameters in Go")

s/parameters/function parameters/

Toggle quote (2 lines)
> + (description "Reports unused function parameters and results in Go code.")

(description
"This package provides a tool for scanning Go code for unused function
parameters and return values.")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhiDAACgkQ7ImHg/nq
I20LfQv8Dhu8OCnmxJtnI3jU0FiLapTQsc0T3pLEJNJPiZYZOMtgz8i5QUSqahKE
zLhfwGYZz5ksGrslO9OQP+Ps2p39e7Uv1TRzLu3rF73iV/YNBJdaSUvJJ/bbcBmO
SFIPr/toaEXao04NVWLn4rRYJicusoUdLvjpOxKpr6vIwFUXmfqgmTEuV7Fob8cE
hfXasmqXV2EIaO0XTe2HPRDW3/zB0IR4ixEvCJTiVhb2pPVd9B7c7ib6dbEbBrnV
DgBoNaOn5jb2JdK/wmC1ZhSg0CEn/tw3oS0qCtkHT47ofCi95d1TBieoVsqVcHlA
qTxi0Z9TgjeOrM85EnLixRcEAD5rpqalRNz9hkkc+C/zTt4N6eKlrMEt8wUtznp1
VZZjJRhEgqSaNPMLPvJx6aIKXKgmQCWsEXG0l3u71s5vZsEN8QMU8Dzk+WLLkoKg
vVtJYWuGBtJAilXZ4271bWmnP6mf/iKvoosa6yuc2Bun8Lo0NcB29dMEfKz54ufT
CvjDlgou
=oaV8
-----END PGP SIGNATURE-----


?