[PATCH 01/25] gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-2-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-golang-org-x-sync): Update to 0.1.0-1.8fcdb60.
---
gnu/packages/golang.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70ddef52f1..9300e675dd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Tomáš ?ech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -3021,11 +3021,11 @@ (define-public go-golang-org-x-image
(license license:bsd-3))))
(define-public go-golang-org-x-sync
- (let ((commit "6e8e738ad208923de99951fe0b48239bfd864f28")
+ (let ((commit "8fcdb60fdcc0539c5e357b2308249e4e752147f1")
(revision "1"))
(package
(name "go-golang-org-x-sync")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.1.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3034,17 +3034,17 @@ (define-public go-golang-org-x-sync
(file-name (git-file-name name version))
(sha256
(base32
- "1avk27pszd5l5df6ff7j78wgla46ir1hhy2jwfl9a3c0ys602yx9"))))
+ "07qrhni6f5hh5p95k1yk6s4wsj341q663irvx6rllrxfsymj6a0z"))))
(build-system go-build-system)
(arguments
`(#:import-path "golang.org/x/sync"
#:tests? #f
;; Source-only package
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
(synopsis "Additional Go concurrency primitives")
- (description "This package provides Go concurrency primitives in addition
+ (description
+ "This package provides Go concurrency primitives in addition
to the ones provided by the language and “sync” and “sync/atomic”
packages.")
(home-page "https://go.googlesource.com/sync/")
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60903] [PATCH 01/25] gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.
CQBOTU31577C.40DDDSBE71KP@guix-framework
Hi,

*paren puts on hazmat suit, safety goggles, and protective gloves*

* gnu/packages/golang.scm (go-golang-org-x-sync): Update to 0.1.0-1.8fcdb60.

This one LGTM.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhRXoACgkQ7ImHg/nq
I20JGgv9GzCxOL61Q2X2TuLeJRQAK4fRHk7JH/hCRCOAkw9ypfJUnA/1cJlWx37+
tgcfunoK164+3LLeq3llOSTzTYu8hmdi5/zJAspWc002ZnhAzdulcAtu3SdJLhyH
nyxstDMKZ7lgWrLOl3m0Z+RoiAycZtAh/1dPdQQ4d3VC9LvgAnDerHQFixy17HLn
D/Soli5Vbt6kPG0F4XEaDdKFtxEau5aLy4ieQotEXdQTf/O750Ye/Yol55VrilcO
GbYpc7gRQEGvf5N+UFTi8Wr6eSg1StZ4JJA5timIZVGC36dTXXCUVkJ8Kiarkk5S
5G+Y5wXeVZdW5mZJXjOrVcqs9pVEqMJ1L1M+ou9JjDcJYcYv9QuT/0fGKcyV0ExE
2biPVOyHDb9xp/s6DeG1gvFDRK9utn80B45JgkITRp0rjxCKPKZ3chUTm8CbWRVG
Md4I7GGzfhcP00wNRodKHXLdhgvir870yq0dNNcL38vn1jwDRgzaN5Qqv1NSqSgz
IoRE7WdD
=YQwc
-----END PGP SIGNATURE-----


?