[PATCH 11/25] gnu: go-golang-org-x-tools: Update to 0.5.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-12-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-golang-org-x-tools): Update to 0.5.0.
---
gnu/packages/golang.scm | 64 ++++++++++++++++++++++++-----------------
1 file changed, 37 insertions(+), 27 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4cef0f61f6..aa5f5ba159 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2883,35 +2883,45 @@ (define-public go-golang-org-x-exp
(license license:bsd-3)))
(define-public go-golang-org-x-tools
- (let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
- (revision "0"))
- (package
- (name "go-golang-org-x-tools")
- (version (git-version "0.1.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/tools")
- (commit commit)))
- (file-name (string-append "go.googlesource.com-tools-"
- version "-checkout"))
- (sha256
- (base32
- "0iinb70xhcjsddgi42ia1n745lx2ibnjdm6m2v666qrk3876vpck"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "golang.org/x/tools"
+ (package
+ (name "go-golang-org-x-tools")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08kx2nndq3sr6xai7403mbsqvz5shxmp2icylfr2fmwagr59cb2n"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; gopls versions are tagged separately, and it is a
+ ;; separate Guix package.
+ (delete-file-recursively "gopls")))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/tools"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
;; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (synopsis "Tools that support the Go programming language")
- (description "This package provides miscellaneous tools that support the
+ (delete 'build))))
+ (propagated-inputs
+ (list
+ go-github-com-yuin-goldmark
+ go-golang-org-x-mod
+ go-golang-org-x-net
+ go-golang-org-x-sys))
+ (synopsis "Tools that support the Go programming language")
+ (description "This package provides miscellaneous tools that support the
Go programming language.")
- (home-page "https://go.googlesource.com/tools/")
- (license license:bsd-3))))
+ (home-page "https://go.googlesource.com/tools/")
+ (license license:bsd-3)))
(define-public go-golang-org-x-crypto
(let ((commit "2aa609cf4a9d7d1126360de73b55b6002f9e052a")
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60909] [PATCH 11/25] gnu: go-golang-org-x-tools: Update to 0.5.0.
CQBTY2QLP9I5.14WXYDV8FQ89I@guix-framework
* gnu/packages/golang.scm (go-golang-org-x-tools): Update to 0.5.0.

LGTM :)

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhfeAACgkQ7ImHg/nq
I234dwwA22w3yM4ynXkuX3WbB7s6a/qfAIjDt2YjHQeLy9uiRnWiO86dZY5mAbyg
GR7vD5syYnV6ht8SHsLvxsUK4pRtC9hXbB0KiYMAWWjDfxHUtQEhsCWiI6sH+jcF
dmJ98v198YfjftuxMlCxnLIuLeFU4VJMtLH9ubhBmQymKNG07PZXLK7Q3T5Rc+XX
5yb6O+Et4ZrMb0VKlLLwZIuxKYxrnAJMrGfht57o/UZj6F8fnt8R+ZdcV06Pujue
2QkUMHjYCNCoiEkz/zv8b4HirJBg0DWa+LfSwsiTBkv3GC2IcGAdX5kgJ6oIxJjp
L5S+IU89T7ZqtEFfoC76cTg9ekCudsN3p/V7aCIDaMdUcGi3czHd84phZrnNqR15
xcQiW+jHZjZMKnbqw+mDf3NcZ3EQukvR/OUvL8Xp6ji3HDJ8v/4HQZIbJ0eGW0WW
sUplxXIi7QpexpHYCE3BgqXbzJBztpX0QtbNKr7QgPNNqUBkvt24iyhD31BIVmPp
2933mpaA
=d5Lb
-----END PGP SIGNATURE-----


?