[PATCH 13/25] gnu: Add go-mvdan-cc-xurls.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-14-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-mvdan-cc-xurls): New variable.
---
gnu/packages/golang.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cabc2a4bab..2b778ac49e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9792,6 +9792,20 @@ (define-public xurls
be used as both a binary and a library.")
(license license:bsd-3)))
+(define-public go-mvdan-cc-xurls
+ (package
+ (inherit xurls)
+ (name "go-mvdan-cc-xurls")
+ (arguments
+ `(#:import-path "mvdan.cc/xurls"
+ #:tests? #f
+ #:install-source? #t
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs (package-inputs xurls))
+ (native-inputs '())
+ (inputs '())))
+
(define-public go-golang-org-x-lint
(let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
(revision "0"))
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60911] [PATCH 13/25] gnu: Add go-mvdan-cc-xurls.
CQBU6R5R8PHF.OKGQX4LXOZY4@guix-framework
* gnu/packages/golang.scm (go-mvdan-cc-xurls): New variable.

Toggle quote (12 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -9792,6 +9792,20 @@ (define-public xurls

> + (arguments
> + `(#:import-path "mvdan.cc/xurls"
> + #:tests? #f
> + #:install-source? #t
> + #:phases (modify-phases %standard-phases
> + (delete 'build))))

Agh, I didn't read this before the previous patch :) I'm not sure whether you
could simplify their arguments, but I suspect you can; could you please have a
go?

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhgIgACgkQ7ImHg/nq
I20LgAwA5ejopC0R1ygbqznpfeHJ7who1pmJn9OlVBUWoFaYBQcfHMBc+CuP52wt
+OO8tKvInvgsam16+CfikfmFDBTuaG0eN1FoiCyMhjLJP835wJxD3Dd4ZtgVunFc
2D/aI92Xp8eJ2GTJN6Mkpzglqvf7mnPU+/Sj3mgirDGeX85XOfGLFXd4L2hsJ0cM
mEy2uciBlOhcEzNEbPZPRAH/hfabov6qNpwZ/Crk/4epqeic4MsFFqLTLSvpDRI/
3VxZL8cXyExwW46Yg7mo1SKnhVId1g1H38TJXyoNMssDb9tQ2sP+YjNoSSVBx9Fu
DyFSExy7C/dhbnQZ7ibukWLhQ18OnPuhzm/yl3NLJsajC8KvuA7u+apT5yXyci1s
/YrGnUQ5p9gj/NeZDMcDkW0kiQ0pobfxQfjAk2lH3scVTa1V1ut3LqP0P8KGvXMy
1+SoFHYL3n1lKst5ZT9pUsmInPDk3/3GXv/a0Z/PFrE3BNSXCzuSgC9dKozBxceb
vLR+lcy8
=8Lmh
-----END PGP SIGNATURE-----


?