[PATCH 03/25] gnu: Add go-golang-org-x-exp.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-4-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-golang-org-x-exp): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5e7fd1fa82..861640435e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2855,6 +2855,33 @@ (define-public go-github-com-hashicorp-hcl-v2
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
+(define-public go-golang-org-x-exp
+ (package
+ (name "go-golang-org-x-exp")
+ (version "0.0.0-20221004215720-b9f4876ce741")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/exp")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "030b929xyg8dpp6f4qbyg63msi6zgzj9sqmvnyphfcrjkqf7nr41"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/exp"
+ ;; Source-only package
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (home-page "https://golang.org/x/exp")
+ (synopsis "Experimental and deprecated Go packages")
+ (description
+ "This subrepository holds experimental and deprecated (in the @code{old}
+directory) packages.")
+ (license license:bsd-3)))
+
(define-public go-golang-org-x-tools
(let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
(revision "0"))
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60901] [PATCH 03/25] gnu: Add go-golang-org-x-exp.
CQBPWLRNHZSZ.2Q4077S5IEJEB@guix-framework
* gnu/packages/golang.scm (go-golang-org-x-exp): New variable.

Toggle quote (6 lines)
> @@ -2855,6 +2855,33 @@ (define-public go-github-com-hashicorp-hcl-v2

> + (description
> + "This subrepository holds experimental and deprecated (in the @code{old}
> +directory) packages.")

How about:

(description
"This package provides deprecated and experimental Go modules.")

instead?

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhUVgACgkQ7ImHg/nq
I21YOwv+P6xmuxQat4Fj6BWDIwTgt/KPEiVPjLx7HREQbT1oUzpXNoKhSvCtzOc0
FAkY2JhI7Y5Ysju4oTmfv2RZXiG+LnZocx722LXG2wWXBk8GF4gAcLmk7+aDRzjE
jZ70IRMhDUUyYUZOW5+nLHffZalf70hbi1oyG2xMdzvoQlaprAdnFeFNB+3qhwoo
GzCgPkZ1JCQ6pxZyi/r9kL7cNS2SaF4En2WrOh1wfG/pnokvnfwZgG9sSPuZznx4
UkERz82fuhaF3djChj/+QQGBFsFGXRM0Ux/2e1bSaWQyBPwc202tj1/b8u2ZzqoX
msBZVQP7k0DIiPY74NbhdBkseuvoZWNxHhhlvIECpZS/EIochNbDrheZ7pY9ls7o
Z6IR1J8ej5VbGO5KyjzYU+VEgm4qHawWSefd32XKypaNwlfJ7mUMBRrtKqPyRyyU
n7C68zwxfHQkDHAO6Y/GMvIzn79/YN68+sU5kfbMC/fqOiW16uWd0mfLUA+uu+cB
OfUexG2L
=klHH
-----END PGP SIGNATURE-----


K
K
Katherine Cox-Buday wrote on 7 Feb 2023 17:28
87v8kdxwx6.fsf@gmail.com
"( via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (15 lines)
> * gnu/packages/golang.scm (go-golang-org-x-exp): New variable.
>
>> @@ -2855,6 +2855,33 @@ (define-public go-github-com-hashicorp-hcl-v2
>
>> + (description
>> + "This subrepository holds experimental and deprecated (in the @code{old}
>> +directory) packages.")
>
> How about:
>
> (description
> "This package provides deprecated and experimental Go modules.")
>
> instead?

Yes, that's better within the Guix context, IMO.

As a guide, I tend to take the package descriptions from upstream's
descriptions in an effort to provide packages that are as close to
upstream as possible. But this kind of conflicts with the ideal of a
distribution providing a curated, holistic, experience.

Should I give more weight to the latter, sometimes at the expense of the
former?

--
Katherine
(
(address . 60901@debbugs.gnu.org)
CQCIJ8X6REOT.3P3TCIAY6VO4G@guix-framework
On Tue Feb 7, 2023 at 4:28 PM GMT, Katherine Cox-Buday wrote:
Toggle quote (3 lines)
> Should I give more weight to the latter, sometimes at the expense of the
> former?

IMO: definitely.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPijNYACgkQ7ImHg/nq
I22cNAv+MVEI3z/+dsveXVl59ufu+I8iZKH4r/XRqYvCEja1GxQUo6k3zAsoNZMf
6i0iBLBNFIqcxLzpP9BWEMZENBs88qD+p5csotS1N7eTDkWVw/9ejtBREXmw9pAu
qNL2DYhrzKFhV9i0MQue1pmQZXYRxA5wQxTwD+oubdIO/JR+K1t4uP30+ishHfEJ
4JWVequX47bZSnbxUvde95sMgxVzWzEKPh9E0lVBNNPc2doHQVq8GD5jzTezoCM1
sl+8npLOeMbpXnGyJt9dpzlpmbVceofPtzgszutvRFwxi8d9peafTkUTvn+F9Rb8
rN2QqNwdXYNav9tkx/+7/P7PAckHuRiX2jq7sd7RsthNQLgwGnQbNTiWaS/ifew1
cEv8N6bIeVH67QFNQYYg14yhtLytrBmiNAB4V5D0UsVTnLguSUFOXyQhJzeajW9R
pCWyeKZtbyT0snwU2PltU2dUzbx7bN2fbT2oEUCdo7AbOCtOZzj+u37DvmwWAZMC
iZdJsuoS
=BEqq
-----END PGP SIGNATURE-----


?