[PATCH 07/25] gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-8-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9.
---
gnu/packages/golang.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aabaa6336c..9554234c7b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7024,28 +7024,27 @@ (define-public go-github-com-fatih-color
(define-public go-github-com-google-go-cmp-cmp
(package
(name "go-github-com-google-go-cmp-cmp")
- (version "0.5.2")
+ (version "0.5.9")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/go-cmp")
- (commit (string-append "v" version))))
+ (url "https://github.com/google/go-cmp")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0qchy411jm9q2l9mf7x3ry2ycaqp9xdhf2nx14qrpzcxfigv2705"))))
+ "0a13m7l1jrysa7mrlmra8y7n83zcnb23yjyg3a609p8i9lxkh1wm"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/google/go-cmp/cmp"
#:unpack-path "github.com/google/go-cmp"))
- (propagated-inputs
- (list go-golang-org-x-xerrors))
(synopsis "Determine equality of values in Go")
- (description "This package provides a more powerful and safer
-alternative to @code{reflect.DeepEqual} for comparing whether two values
-are semantically equal in Go (for writing tests).")
- (home-page "https://godoc.org/github.com/google/go-cmp/cmp")
- (license license:asl2.0)))
+ (description
+ "This package is intended to be a more powerful and safer
+alternative to @@code{reflect.DeepEqual} for comparing whether two values are
+semantically equal.")
+ (home-page "https://github.com/google/go-cmp")
+ (license license:bsd-3)))
(define-public go-github-com-google-uuid
(package
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60907] [PATCH 07/25] gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.
CQBTVQMHN0FV.3UOTOYJ5Z8AZB@guix-framework
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9.

Toggle quote (10 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -7024,28 +7024,27 @@ (define-public go-github-com-fatih-color

> + (description
> + "This package is intended to be a more powerful and safer
> +alternative to @@code{reflect.DeepEqual} for comparing whether two values are
> +semantically equal.")

This is a full sentence, but it doesn't really read well to me. Also, there
should only be one ``@'' in ``@code{...}'', and "more powerful and safer" is
a bit vague :)

What about this?:

(description
"This package provides an alternative to the built-in @code{reflect.DeepEqual}
function for checking if two values are semantically equal. The advantages
over the builtin function include:

@enumerate
[etc etc :)]
@end enumerate")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhfSkACgkQ7ImHg/nq
I20HdAv9HkQ18UyRA56GV3tJT0uXJbfgURKub9+R0e25LLtF5s9MRljpwnxzMlq5
rd37qJOouOdbhT2bbT/KyK2DEBzfUV42eFax7Hm8bByopGkgscoFq/pu38q/VmUW
DDcx0PScjAVypCYKVqc2NpOyvTJ/SohByHdsKoS5cebz4Pe1wRr7GAWmQclpuUks
0ZzK5PbxgCBQlDUKRCU9XSoxjfg3Gwyaw2mZaIaEQghV/VrrmHXFe2goJ0qHGdLT
7DyJxdvH/J4Q8MxM90Wnmc5R9SVEJpWOOLx6QH3q2ftXI7R8cMGa0caZMIxelIl9
z80pSowZG5w0aFwvhPP9rHNZZ9iujDU41U6Z3yV16kHJVG9aSlhxT2ZPCeYseX+o
yPUJN0b2UElqJ5O4U7caX9mNp+PdIv5UVEKwwN1O2Nhh4zwqgt7LJZRzmNNi/jQc
Os1oAdPUZ5Ngg1Uug2ivCd83P8Y/TVAayRs550nUiBmMNm5DMzFhbjf92zf43N++
fQPGAx55
=/BMj
-----END PGP SIGNATURE-----


K
K
Katherine Cox-Buday wrote on 7 Feb 2023 18:28
(name . ( via Guix-patches via)(address . guix-patches@gnu.org)
877cwtxu55.fsf@gmail.com
"( via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (16 lines)
> * gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9.
>
>> --- a/gnu/packages/golang.scm
>> +++ b/gnu/packages/golang.scm
>
>> @@ -7024,28 +7024,27 @@ (define-public go-github-com-fatih-color
>
>> + (description
>> + "This package is intended to be a more powerful and safer
>> +alternative to @@code{reflect.DeepEqual} for comparing whether two values are
>> +semantically equal.")
>
> This is a full sentence, but it doesn't really read well to me. Also,
> there should only be one ``@'' in ``@code{...}'', and "more powerful
> and safer" is a bit vague :)

I'd only intended this to be a version bump. Maybe I updated the
description based on feedback from `guix style` or `guix lint`.

At any rate, I agree the description is not very helpful, and uses
superlatives, which the manual calls out as an anti-pattern.

Toggle quote (12 lines)
>
> What about this?:
>
> (description
> "This package provides an alternative to the built-in @code{reflect.DeepEqual}
> function for checking if two values are semantically equal. The advantages
> over the builtin function include:
>
> @enumerate
> [etc etc :)]
> @end enumerate")

I like this much more, although I don't know enough about it to
enumerate the benefits. If I can discover those, I'll enumerate them :)

--
Katherine
?