[PATCH 00/25] gnu: golang: Add gopls

  • Done
  • quality assurance status badge
Details
4 participants
  • Katherine Cox-Buday
  • Christopher Baines
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-1-cox.katherine.e@gmail.com
This is a patch series to add the gopls package.

I haven't contributed to many projects which use the e-mail flow, so hopefully
I'm doing this correctly. Please feel free to make suggestions if not!

Some of the diffs are a little busier than I'd like for version bumps. This is
due to running `guix style` over everything.

For all of the packages I have:

. Run guix style
. Run guix lint
. Built 2x
. Checked that the change is in the correct branch
. Built all dependencies
. Built the repository

Katherine Cox-Buday (25):
gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.
gnu: go-golang-org-x-mod: Update to 0.7.0.
gnu: Add go-golang-org-x-exp.
gnu: Add go-github-com-jba-printsrc.
gnu: Add go-github-com-google-safehtml.
gnu: Add go-github-com-jba-templatecheck.
gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.
gnu: go-github-com-pkg-diff: Update to
0.0.0-20210226163009-20ebb0f2a09e.
gnu: go-github-com-rogpeppe-go-internal: Update to 1.9.0.
gnu: gopkg-in-errgo-fmt-errors: Rename package to
go-gopkg-in-errgo-fmt-errors.
gnu: go-golang-org-x-tools: Update to 0.5.0.
gnu: Add xurls.
gnu: Add go-mvdan-cc-xurls.
gnu: Add misspell.
gnu: Add go-github-com-client9-misspell.
gnu: Add go-github-com-google-go-cmdtest.
gnu: Add unparam.
gnu: Add go-mvdan-cc-unparam.
gnu: Add govulncheck.
gnu: Add go-golang-org-x-vuln.
gnu: go-github-com-burntsushi-toml: Update to 1.2.1.
gnu: go-honnef-co-go-tools: Update to 0.3.3.
gnu: Add gofumpt.
gnu: Add go-mvdan-cc-gofumpt.
gnu: Add gopls.

gnu/packages/configuration-management.scm | 2 +-
gnu/packages/golang.scm | 695 ++++++++++++++++++----
2 files changed, 578 insertions(+), 119 deletions(-)


base-commit: 5c921977179489caef4a9e54ada6696fc86d2f0b
--
2.38.1
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:45
[PATCH 25/25] gnu: Add gopls.
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-26-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (gopls): New variable.
---
gnu/packages/golang.scm | 45 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3dcd97a8c1..faa6c61bc4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3021,6 +3021,51 @@ (define-public go-golang-org-x-vuln
(native-inputs '())
(inputs '())))
+(define-public gopls
+ (package
+ (name "gopls")
+ (version "0.11.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/tools")
+ (commit (string-append "gopls/v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l9y1rp7x51s6dnjn227fhdlnz4z1h41jn3x1aq49qki241w7m73"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/tools/gopls"
+ #:unpack-path "golang.org/x/tools"
+ #:install-source? #f
+ #:phases (modify-phases %standard-phases
+ (add-before 'unpack 'override-tools
+ (lambda _
+ (delete-file-recursively "src/golang.org/x/tools"))))))
+ (propagated-inputs (list go-github-com-google-go-cmp-cmp
+ go-github-com-jba-printsrc
+ go-github-com-jba-templatecheck
+ go-github-com-sergi-go-diff
+ go-golang-org-x-mod
+ go-golang-org-x-sync
+ go-golang-org-x-sys
+ go-golang-org-x-text
+ go-gopkg-in-yaml-v3
+ go-honnef-co-go-tools
+ go-github-com-burntsushi-toml
+ go-github-com-google-safehtml
+ go-golang-org-x-exp
+ go-mvdan-cc-gofumpt
+ go-golang-org-x-vuln
+ go-mvdan-cc-xurls))
+ (home-page "https://golang.org/x/tools/gopls")
+ (synopsis "Official language server for the Go language")
+ (description
+ "Pronounced \"Go please\", this is the official Go language server developed by
+the Go team. It provides IDE features to any LSP-compatible editor.")
+ (license license:bsd-3)))
+
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
K
K
Katherine Cox-Buday wrote on 30 Jan 2023 17:53
Request for review of: [bug#60899] [PATCH 00/25] gnu: golang: Add gopls
878rhkyney.fsf@gmail.com
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

Toggle quote (54 lines)
> This is a patch series to add the gopls package.
>
> I haven't contributed to many projects which use the e-mail flow, so
> hopefully I'm doing this correctly. Please feel free to make
> suggestions if not!
>
> Some of the diffs are a little busier than I'd like for version bumps.
> This is due to running `guix style` over everything.
>
> For all of the packages I have:
>
> . Run guix style
> . Run guix lint
> . Built 2x
> . Checked that the change is in the correct branch
> . Built all dependencies
> . Built the repository
>
> Katherine Cox-Buday (25):
> gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.
> gnu: go-golang-org-x-mod: Update to 0.7.0.
> gnu: Add go-golang-org-x-exp.
> gnu: Add go-github-com-jba-printsrc.
> gnu: Add go-github-com-google-safehtml.
> gnu: Add go-github-com-jba-templatecheck.
> gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.
> gnu: go-github-com-pkg-diff: Update to
> 0.0.0-20210226163009-20ebb0f2a09e.
> gnu: go-github-com-rogpeppe-go-internal: Update to 1.9.0.
> gnu: gopkg-in-errgo-fmt-errors: Rename package to
> go-gopkg-in-errgo-fmt-errors.
> gnu: go-golang-org-x-tools: Update to 0.5.0.
> gnu: Add xurls.
> gnu: Add go-mvdan-cc-xurls.
> gnu: Add misspell.
> gnu: Add go-github-com-client9-misspell.
> gnu: Add go-github-com-google-go-cmdtest.
> gnu: Add unparam.
> gnu: Add go-mvdan-cc-unparam.
> gnu: Add govulncheck.
> gnu: Add go-golang-org-x-vuln.
> gnu: go-github-com-burntsushi-toml: Update to 1.2.1.
> gnu: go-honnef-co-go-tools: Update to 0.3.3.
> gnu: Add gofumpt.
> gnu: Add go-mvdan-cc-gofumpt.
> gnu: Add gopls.
>
> gnu/packages/configuration-management.scm | 2 +-
> gnu/packages/golang.scm | 695 ++++++++++++++++++----
> 2 files changed, 578 insertions(+), 119 deletions(-)
>
>
> base-commit: 5c921977179489caef4a9e54ada6696fc86d2f0b

Hello Guix! Acknowledging that everyone are volunteers, and busy (guilty
myself), this is a humble request for a review of this patch-series I
made two weeks ago so that it doesn't bit-rot.

I have a `gopls` home service[1] waiting to be proposed after this
patch-series is merged.

Thank you very much!


P.S. I think I am following etiquette for review reminders (i.e. waiting
long enough, bringing this over to guix-devel), but I was having trouble
finding examples. If I haven't waited long enough, or have reminded in
the wrong way, please give me feedback.

--
Katherine
K
K
Katherine Cox-Buday wrote on 6 Feb 2023 17:53
(address . 60899@debbugs.gnu.org)(name . Guix Devel)(address . guix-devel@gnu.org)
87edr2zqed.fsf@gmail.com
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

Toggle quote (73 lines)
> Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
>
>> This is a patch series to add the gopls package.
>>
>> I haven't contributed to many projects which use the e-mail flow, so
>> hopefully I'm doing this correctly. Please feel free to make
>> suggestions if not!
>>
>> Some of the diffs are a little busier than I'd like for version bumps.
>> This is due to running `guix style` over everything.
>>
>> For all of the packages I have:
>>
>> . Run guix style
>> . Run guix lint
>> . Built 2x
>> . Checked that the change is in the correct branch
>> . Built all dependencies
>> . Built the repository
>>
>> Katherine Cox-Buday (25):
>> gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.
>> gnu: go-golang-org-x-mod: Update to 0.7.0.
>> gnu: Add go-golang-org-x-exp.
>> gnu: Add go-github-com-jba-printsrc.
>> gnu: Add go-github-com-google-safehtml.
>> gnu: Add go-github-com-jba-templatecheck.
>> gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.
>> gnu: go-github-com-pkg-diff: Update to
>> 0.0.0-20210226163009-20ebb0f2a09e.
>> gnu: go-github-com-rogpeppe-go-internal: Update to 1.9.0.
>> gnu: gopkg-in-errgo-fmt-errors: Rename package to
>> go-gopkg-in-errgo-fmt-errors.
>> gnu: go-golang-org-x-tools: Update to 0.5.0.
>> gnu: Add xurls.
>> gnu: Add go-mvdan-cc-xurls.
>> gnu: Add misspell.
>> gnu: Add go-github-com-client9-misspell.
>> gnu: Add go-github-com-google-go-cmdtest.
>> gnu: Add unparam.
>> gnu: Add go-mvdan-cc-unparam.
>> gnu: Add govulncheck.
>> gnu: Add go-golang-org-x-vuln.
>> gnu: go-github-com-burntsushi-toml: Update to 1.2.1.
>> gnu: go-honnef-co-go-tools: Update to 0.3.3.
>> gnu: Add gofumpt.
>> gnu: Add go-mvdan-cc-gofumpt.
>> gnu: Add gopls.
>>
>> gnu/packages/configuration-management.scm | 2 +-
>> gnu/packages/golang.scm | 695 ++++++++++++++++++----
>> 2 files changed, 578 insertions(+), 119 deletions(-)
>>
>>
>> base-commit: 5c921977179489caef4a9e54ada6696fc86d2f0b
>
> Hello Guix! Acknowledging that everyone are volunteers, and busy (guilty
> myself), this is a humble request for a review of this patch-series I
> made two weeks ago so that it doesn't bit-rot.
>
> I have a `gopls` home service[1] waiting to be proposed after this
> patch-series is merged.
>
> Thank you very much!
>
> [1]
> https://github.com/kat-co/guix-channels/blob/upstream-staging/upstream/home/services/gopls.scm
>
> P.S. I think I am following etiquette for review reminders (i.e. waiting
> long enough, bringing this over to guix-devel), but I was having trouble
> finding examples. If I haven't waited long enough, or have reminded in
> the wrong way, please give me feedback.

Hello, this is another humble request for review :)

It looks like QA is passing, and I think I did a pretty thorough job of
making sure things follow standards and will apply cleanly.

--
Katherine
C
C
Christopher Baines wrote on 7 Feb 2023 00:14
Re: [bug#60899] [PATCH 00/25] gnu: golang: Add gopls
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
87cz6mcrnq.fsf@cbaines.net
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

Toggle quote (50 lines)
> This is a patch series to add the gopls package.
>
> I haven't contributed to many projects which use the e-mail flow, so hopefully
> I'm doing this correctly. Please feel free to make suggestions if not!
>
> Some of the diffs are a little busier than I'd like for version bumps. This is
> due to running `guix style` over everything.
>
> For all of the packages I have:
>
> . Run guix style
> . Run guix lint
> . Built 2x
> . Checked that the change is in the correct branch
> . Built all dependencies
> . Built the repository
>
> Katherine Cox-Buday (25):
> gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.
> gnu: go-golang-org-x-mod: Update to 0.7.0.
> gnu: Add go-golang-org-x-exp.
> gnu: Add go-github-com-jba-printsrc.
> gnu: Add go-github-com-google-safehtml.
> gnu: Add go-github-com-jba-templatecheck.
> gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.
> gnu: go-github-com-pkg-diff: Update to
> 0.0.0-20210226163009-20ebb0f2a09e.
> gnu: go-github-com-rogpeppe-go-internal: Update to 1.9.0.
> gnu: gopkg-in-errgo-fmt-errors: Rename package to
> go-gopkg-in-errgo-fmt-errors.
> gnu: go-golang-org-x-tools: Update to 0.5.0.
> gnu: Add xurls.
> gnu: Add go-mvdan-cc-xurls.
> gnu: Add misspell.
> gnu: Add go-github-com-client9-misspell.
> gnu: Add go-github-com-google-go-cmdtest.
> gnu: Add unparam.
> gnu: Add go-mvdan-cc-unparam.
> gnu: Add govulncheck.
> gnu: Add go-golang-org-x-vuln.
> gnu: go-github-com-burntsushi-toml: Update to 1.2.1.
> gnu: go-honnef-co-go-tools: Update to 0.3.3.
> gnu: Add gofumpt.
> gnu: Add go-mvdan-cc-gofumpt.
> gnu: Add gopls.
>
> gnu/packages/configuration-management.scm | 2 +-
> gnu/packages/golang.scm | 695 ++++++++++++++++++----
> 2 files changed, 578 insertions(+), 119 deletions(-)

I've made a few tweaks and pushed this to master as
f3ab5888a0bc6446104ddbba41a413a86eb298e2.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmPhiflfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfhig//YSPLrs7Avr27xXjqeKZFwOVPHnrKcIPO
LfG5EXjG+AiRQ1bR3vmV3+N6fN/Z3e9p3N9NE9T04ZZCWpSPW+A0d87gEdL3hfz6
a5fIXW05SYr8cFYaxjqk81W3pT9ADWOoXHVq8yMDPOA/yLUH4NUUj0HCK1CNwHs4
elbKi6o6LErFeuSjBk9xIVhjtrQWtFW25Mobx66yjyZ4IdRK5jHcTLr0vFSXLTAp
6r04cKhQxLGlz1GAce5AO4hgDXXyjYSKuRjyrGD2/q2QBJFTH08XIs7GUNpH1E8u
yOqv+/kch/3GGKl8UN5SU1Dyg76uB7nLGqhKD13ZFpqoasfdOfY+O5pF1GBjYT1b
1zDBO1E3MqDGMC4nQ5HZBAMu/zwtCPfhOgjCQPHQVNaENdwwcNVvO7uMB4YMFLd/
da/ZoYgd39GvPQl3ciUqr2tO7B5NaiTzKyC5RdiS9nM+pidZ52pbLfxyE/ZNDkhU
5bQDwoApnhp2ZWLW/gJr/RIVefSAk4PrH9r4rbblNsNQe1tNHPP9pMcYZSTAeyLq
aWDPRjNYUMay93LqmmIyUu0Ve0OB9Fmy/jb5BmpvuqfOviprazJQtbyl9Wcpf1Ws
1qIAIG9Wr20k+dd8YFf/EsieNvFaOAb7NY06KM8dEK30yN3wZjrk7qXpe7QWModp
/slginLeq+4=
=3TGe
-----END PGP SIGNATURE-----

(
Re: bug#60899: [PATCH 00/25] gnu: golang: Add gopls
CQBVC0F7N9PK.66C9L4GJ6310@guix-framework
On Mon Feb 6, 2023 at 11:14 PM GMT, Christopher Baines wrote:
Toggle quote (3 lines)
> I've made a few tweaks and pushed this to master as
> f3ab5888a0bc6446104ddbba41a413a86eb298e2.

Nooo, my review was too slow :P

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhjSkACgkQ7ImHg/nq
I22LMwv/eep45UWbi+nB+9l5sK80FwF4lb633EwCvBrGOk57w6VPYDQmm7kQHQZr
03GD7DnIWzhaGdcJBb+B2DwfJJxgSpQTfNWPhuKAOeQJcwV/UskFpIMYlJc79M19
QLlR8zFIF5TIZXS6LKeEucpav/5YC+vdLkKrdTkpDUOfUCqYaDB19AQ/eooatH80
/Vw52iEFVGepybS1rUdqTvM5wiwP7gOQ+06pw0j1zspqUXVchRfvSEM62LCFGjNZ
Vzm+uQgQAx71xblG5Up5lA5S14402tSjJv1+k6UKFfbauzWQM6ohrguzmRVSys54
VqtiXoa6i13oVBZN3l7xrNmNTCH7HbMIXHp8SLEhWdwcgKhhnxT3d2RaI5snnmGK
wvwt0ua7hHctT4PHdakytHB7saEoA+covc6YC6+s+0PSPRS5ivzrLkmLYmkiviql
k2s9HH66La3933AvKO8GYKeV87XnT4JwLddjKVKHHQVWHImNL28LVZsgS4pRdOvH
wG0UxBc7
=pUv8
-----END PGP SIGNATURE-----


(
Re: [bug#60899] [PATCH 25/25] gnu: Add gopls.
CQBVBNP2GGA7.DM4HUTOEBS44@guix-framework
* gnu/packages/golang.scm (gopls): New variable.

Toggle quote (14 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -3021,6 +3021,51 @@ (define-public go-golang-org-x-vuln

> + (arguments
> + `(#:import-path "golang.org/x/tools/gopls"
> + #:unpack-path "golang.org/x/tools"
> + #:install-source? #f
> + #:phases (modify-phases %standard-phases
> + (add-before 'unpack 'override-tools
> + (lambda _
> + (delete-file-recursively "src/golang.org/x/tools"))))))

s/override/remove-other/, perhaps?

Toggle quote (17 lines)
> + (propagated-inputs (list go-github-com-google-go-cmp-cmp
> + go-github-com-jba-printsrc
> + go-github-com-jba-templatecheck
> + go-github-com-sergi-go-diff
> + go-golang-org-x-mod
> + go-golang-org-x-sync
> + go-golang-org-x-sys
> + go-golang-org-x-text
> + go-gopkg-in-yaml-v3
> + go-honnef-co-go-tools
> + go-github-com-burntsushi-toml
> + go-github-com-google-safehtml
> + go-golang-org-x-exp
> + go-mvdan-cc-gofumpt
> + go-golang-org-x-vuln
> + go-mvdan-cc-xurls))

Could this be changed to just ``inputs''?

Toggle quote (4 lines)
> + (description
> + "Pronounced \"Go please\", this is the official Go language server developed by
> +the Go team. It provides IDE features to any LSP-compatible editor.")

(description
"This package provides the official @acronym{LSP, language server protocol}
server for the Go language, allowing LSP-compatible editors to automatically
support @acronym{IDE, integrated development environment}-like features.")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhjQ0ACgkQ7ImHg/nq
I21Vcwv+PMfnUrn8tdLUvT1om7zBTvmrUUx7eUju4KxxGrfrpImt70a+uzQ4kClu
g2DZWHAMWQI58+J6QRkeMlp4fTMqlX37FkrvRuVpQ/EooUfWeqAqEyDiSBlJSHuJ
XldmRGwDzQ3/zoTuklBtHtdkWYfEXbDpjSW6YjUAGRK9oP498FFY/UTJa5m6jZIl
VQdiv1hhgqsV139zqdgsx9UAGeEfrNDKXf9CnqSx6OL1yceqPsoG6RjMW6K4MDb9
X/5IuebNCbVcAgQ8ArW+5FnUUf2b8QjR+3fFEIAVRhRp1u7Q5Ueh33HWi66iOC8Z
mh6wj/M+4PYo+J9/nPXD9IBp1OjzkMud08CWetKjJSiVBPqdKi8xEjpZHNHQcykE
2B6D3Dq91bpBs91SLbkpBPL4bnYvAabuoK0GsCOeT/qSX8bI3Bg7PvW8JjX8JmJo
9jVAUw46WzGyuNJOUjuVQe159BlniXvBaGptiecBoUsWqSuACAdKDYrHlIxZ52XH
MZpwWfNS
=UbOc
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 7 Feb 2023 08:42
Re: bug#60899: [PATCH 00/25] gnu: golang: Add gopls
(name . ()(address . paren@disroot.org)
878rh9didm.fsf@cbaines.net
"(" <paren@disroot.org> writes:

Toggle quote (7 lines)
> [[PGP Signed Part:Undecided]]
> On Mon Feb 6, 2023 at 11:14 PM GMT, Christopher Baines wrote:
>> I've made a few tweaks and pushed this to master as
>> f3ab5888a0bc6446104ddbba41a413a86eb298e2.
>
> Nooo, my review was too slow :P

I think reviewing changes/sending feedback after things have been merged
is fine (and important). If more people get involved in reviewing
things, this is probably something that'll happen more, so I think for
now it's good to embrace it.

Hopefully we can continue the discussion around these changes and
perhaps further improve things with some additional patches.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmPiArVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfnlg/7BLYjj1+bj2Y3TP4Kww7t4Ley4VpeQEjL
jdElYggdSLiYNlc5QKuSrcWsaCLWHUdE2lDCQGZ20m5Wt8iyjwEaRcWw/S5TwFmk
UDDg3zDHD2WIfW/Xm71ShNjCtAE28MNqE9/fUIXGaSdO1rxEBsnLIPpeSWtbwjPb
P21p+6uoX8KwdO+PCC/jKUBoL2XraXD6RKJDyzJfKqv2qb6fOP0tyz4w8j57t8HO
DGNwNAtuKNNHRvekCQyQrq2heuibrJiFy27yuf+926xicKnGpzWtF7r//lEvSeIj
Msq5AJ9myq50Oq7sLBBwDt4C1r80YTYxIC/pdjeaWa8PclhtqiTJ9DQn+cjvHR0I
bViD3pwoVOqIpMo+ppOdcU700YCBzkW3sfEbB2WDFmh55HcL6NJZbHaHyrLcFNiD
dRUwcBDWaNE6P/sPQAHy4iYz8kaNAP1n1rKSDA7DXnYp3FTIk321YN0Y/mqntlld
5Df/LYaVFtxJnQ1tmRUTBsUKKvtZNy1E6+/AnvC4dPCL+WEybCPjqjkPRwbe3y24
veJ+gqDPJqGhTAp9ZHj3og+IoaCx3RT6ikDD8MNIgjwrLK5+bLBxsyePZjy4zNvF
2c3YWHHXL3T07iRQOYnoWYBN3mz0FoXABbPXcSBR+FV/sZwAt9WPvKstvAR7ROh+
8Ie5UK+uCYA=
=6aGL
-----END PGP SIGNATURE-----

K
K
Katherine Cox-Buday wrote on 7 Feb 2023 16:59
(address . 60899@debbugs.gnu.org)(address . mail@cbaines.net)
87a61pzcsm.fsf@gmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (7 lines)
> I've made a few tweaks and pushed this to master as
> f3ab5888a0bc6446104ddbba41a413a86eb298e2.
>
> Thanks,
>
> Chris

Thank you so much!

I'm going to review the changes (and the reviews from open-paren) to try
and incorporate that going forward.

--
Katherine
K
K
Katherine Cox-Buday wrote on 7 Feb 2023 17:02
Re: [bug#60899] [PATCH 00/25] gnu: golang: Add gopls
(name . Christopher Baines)(address . mail@cbaines.net)
875ycdzcor.fsf@gmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (19 lines)
> "(" <paren@disroot.org> writes:
>
>> [[PGP Signed Part:Undecided]]
>> On Mon Feb 6, 2023 at 11:14 PM GMT, Christopher Baines wrote:
>>> I've made a few tweaks and pushed this to master as
>>> f3ab5888a0bc6446104ddbba41a413a86eb298e2.
>>
>> Nooo, my review was too slow :P
>
> I think reviewing changes/sending feedback after things have been merged
> is fine (and important). If more people get involved in reviewing
> things, this is probably something that'll happen more, so I think for
> now it's good to embrace it.
>
> Hopefully we can continue the discussion around these changes and
> perhaps further improve things with some additional patches.
>
> Chris

I responded to Chris's original message, but: +1 to what Chris says. I'm
still going to look at your feedback, paren, and maybe send some more
patches.

Personally, I prefer always moving forward, so long as it doesn't break
anything.

Thank you very much for the reviews!

--
Katherine
?