[PATCH 04/25] gnu: Add go-github-com-jba-printsrc.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-5-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-github-com-jba-printsrc): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 861640435e..677d58d831 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8515,6 +8515,32 @@ (define-public go-github-com-go-git-go-billy
file system operations.")
(license license:asl2.0)))
+(define-public go-github-com-jba-printsrc
+ (package
+ (name "go-github-com-jba-printsrc")
+ (version "0.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jba/printsrc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gyy3kmb5a5i710wkv3b7ah7i7sz5sdc7v3sab5m4rxch1sd2fpj"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jba/printsrc"
+ ;; TODO: Open bug; expecting time.Local, but when local=UTC, we get time.UTC
+ #:tests? #f))
+ (home-page "https://github.com/jba/printsrc")
+ (synopsis "Prints Go values as sourcecode")
+ (description
+ "Package printsrc prints Go values as Go source. It strives to render
+legal Go source code, and returns an error when detects that it cannot.")
+ ;; MIT
+ (license license:expat)))
+
(define-public go-github-com-jbenet-go-context
(let ((commit "d14ea06fba99483203c19d92cfcd13ebe73135f4")
(revision "1"))
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60900] [PATCH 04/25] gnu: Add go-github-com-jba-printsrc.
CQBPYCYYUD5C.14L98S5FMK2LT@guix-framework
* gnu/packages/golang.scm (go-github-com-jba-printsrc): New variable.

Toggle quote (9 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -8515,6 +8515,32 @@ (define-public go-github-com-go-git-go-billy

> + (arguments
> + '(#:import-path "github.com/jba/printsrc"
> + ;; TODO: Open bug; expecting time.Local, but when local=UTC, we get time.UTC

Please add the bug report URL.

Toggle quote (4 lines)
> + (description
> + "Package printsrc prints Go values as Go source. It strives to render
> +legal Go source code, and returns an error when detects that it cannot.")

(description
"This package provides a Go library for printing Go values as legal source
code, and attempts to detect when this is not possible."

Toggle quote (2 lines)
> + ;; MIT

Redundant comment :)

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhUeIACgkQ7ImHg/nq
I23IWAv+MmNYd0iUk9/NA/4ISpozHjWFWGTgHMLeYVZzheZZ/ftAVDt4FKEp1HxP
dHNNFKoyXEQBFW/kRYn8x5+b3kQZEdCd0BnUDEWR8ZiK6pTwrvqaVmepq5NNvV6L
H3Z/LFiVVfn3FwnVvG1DkQnUJbpUt4gvPK+bopBaGt/Q2LjynnmOhVLqgC8Dopp3
diImq+AUNkrFtf08+FqXn/jS74/0NbvayP3kNCTyyShBQQK/bBdrXJwGZCY7noQh
wVxGctLStSQ1WCt+wCn4QBg7ZdtYuOyKwU1jlyW2OmIEqSPOLxAfv4EM4OEf/Q6o
l84jXE2qVTZp4FPWvdqCfZzI40J/+ionzyBZZkWf03Pc0CPnWPxInSc1qc6SK0pw
o8yx/zg/jRFQJHo03hkbwjPUeOR8xnhQsnCxg8exw0A7Nm5Y40T457sf5601GAXY
cTz2m1Pk9FQJ2eNoM8P300V/8RZ2ET2jdUMLw8KohFDYCPfiEX89e1QYHpaB4G5x
/NQYcE0o
=JMpE
-----END PGP SIGNATURE-----


?