[PATCH 21/25] gnu: go-github-com-burntsushi-toml: Update to 1.2.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:45
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-22-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-github-com-burntsushi-toml): Update to 1.2.1.
---
gnu/packages/golang.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 26cd636c64..660deceec5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3328,23 +3328,23 @@ (define-public go-golang-org-x-mod
(define-public go-github-com-burntsushi-toml
(package
(name "go-github-com-burntsushi-toml")
- (version "0.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/BurntSushi/toml")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1fjdwwfzyzllgiwydknf1pwjvy49qxfsczqx5gz3y0izs7as99j6"))))
+ (version "1.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BurntSushi/toml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v9czq4hsyvdz7yx70y6sgq77wmrgfmn09r9cj4w85z38jqnamv7"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/BurntSushi/toml"))
(home-page "https://github.com/BurntSushi/toml")
(synopsis "Toml parser and encoder for Go")
- (description "This package is toml parser and encoder for Go. The interface
+ (description
+ "This package is toml parser and encoder for Go. The interface
is similar to Go's standard library @code{json} and @code{xml} package.")
(license license:expat)))
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60917] [PATCH 21/25] gnu: go-github-com-burntsushi-toml: Update to 1.2.1.
CQBUZUCRPHCN.30RN5XCHE2QIZ@guix-framework
* gnu/packages/golang.scm (go-github-com-burntsushi-toml): Update to 1.2.1.

Toggle quote (7 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -3328,23 +3328,23 @@ (define-public go-golang-org-x-mod

> (synopsis "Toml parser and encoder for Go")

(synopsis "Parsing for TOML in Go")

Toggle quote (4 lines)
> + (description
> + "This package is toml parser and encoder for Go. The interface
> is similar to Go's standard library @code{json} and @code{xml} package.")

(description
"This package provides a Go library for parsing the TOML configuration
language, similar to the standard @code{json} and @code{xml} packages.")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhiW8ACgkQ7ImHg/nq
I23ZVwwA0kvxfgK+pLi+dp9X8plg4WmLoMDK1O7uAj3c1Xie1rQWIX3TzFcRzccw
25/dYCSO0ztUlbxUyDmkQXbPXP9nKlKUD5HzJm70fHG7pQMWcLoqfBlxQP445E+9
axO6WsxSRRCeNTX7Pbmf89hvmA3M4XRRuhsJrvU+HDkc0l/Idlez0QAnNu25STaj
e7ke378x/coxngXEUqGYcGrW1NRBkIO3uDPVhVQw7xS43LuJsK4rvG2k7es1MOiV
U8jSosZfSIYH/m1MLHazVn3ixprNKfF1RwwfD19/YJUCy8D88ihwTYSdigtTU2kK
UqpcJSY04woMdYEXMqOyIog7nOfPZathc+vcCaQV/vnqpruhYejsHKHZ1xYLjFwX
VpuD+o8tRnBkgxKCWWfcS9Th3FugDTffPC2AAma9H6RPMejFiAtmcWSnPLS8rXHz
9zM0v16qCA7bsVi3+z0FaCT1+k5SRkzcdESLdDADTlaeleueWU/4KniL/9IeHHPX
StGODiaf
=LVqL
-----END PGP SIGNATURE-----


?