[PATCH 16/25] gnu: Add go-github-com-google-go-cmdtest.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:45
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-17-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-github-com-google-go-cmdtest): New variable.
---
gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fe45b29215..ced6438581 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11044,6 +11044,35 @@ (define-public go-github-com-google-go-jsonnet
implementation.")
(license license:asl2.0)))
+(define-public go-github-com-google-go-cmdtest
+ (let ((commit "55ab3332a786118933ddf71544aae14951ba9bc5")
+ (revision "0"))
+ (package
+ (name "go-github-com-google-go-cmdtest")
+ (version (git-version "0.4.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-cmdtest")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10kswvbdwissjb5mr0ys4b3ppxkxlpklqg7cr2z7rv21g2vwczbl"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/go-cmdtest"))
+ (propagated-inputs (list go-github-com-google-renameio
+ go-github-com-google-go-cmp-cmp))
+ (home-page "https://github.com/google/go-cmdtest")
+ (synopsis "Testing your CLI")
+ (description
+ "The cmdtest package simplifies testing of command-line interfaces. It provides
+a simple, cross-platform, shell-like language to express command execution. It
+can compare actual output with the expected output, and can also update a file
+with new \"golden\" output that is deemed correct.")
+ (license license:asl2.0))))
+
(define-public go-github-com-google-safehtml
(package
(name "go-github-com-google-safehtml")
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60913] [PATCH 16/25] gnu: Add go-github-com-google-go-cmdtest.
CQBUTXRZVPYV.3HRFQJHGLSEBM@guix-framework
* gnu/packages/golang.scm (go-github-com-google-go-cmdtest): New variable.

Toggle quote (7 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -11044,6 +11044,35 @@ (define-public go-github-com-google-go-jsonnet

> + (synopsis "Testing your CLI")

(synopsis "Test Go command line tools")

Toggle quote (6 lines)
> + (description
> + "The cmdtest package simplifies testing of command-line interfaces. It provides
> +a simple, cross-platform, shell-like language to express command execution. It
> +can compare actual output with the expected output, and can also update a file
> +with new \"golden\" output that is deemed correct.")

(description
"This package provides a Go library to simplify the testing of @acronym{CLI}s.")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhh6EACgkQ7ImHg/nq
I23nZAv/cIQdIXc3X58NOkKdTiRG4zIHgHfIx8PL46Tpx7hTN6f7unPxNXKuDs8k
kcqRRshtFEv05I6x7gvI1vjlwmYz7i/IJ6gQJ03yO8+JaWFCqvp1yAsidKh+/NO2
NOEuwCVAaJUlBgTBWWTY+XgDTGYXZSWTmYcNg7gO1b9I1Mki7zTBLlMz4EAJmroL
iQMMUipO0BAOKk6jWqnhildlMBoZbVKH2YsuK2L6uwgNBKoorfaTT3H69oS93jNn
g2oOfa+btQLMVlbbElMy2jQfpo/TLXxO1JyC+OrhWSBFMbcQG6pnlH1lEW49uLgX
zO10McxPBGo6wDacdKqF880kbaAIh41+elDlxcSYGyya1KDg6GA4q1KN1G9En79y
3rnve3mUHzC+8L22VANl/QyCCcCI0zAQ/JKDKjRRbWrRUy137UiaJg58+M4xkwwG
8XQUQ+RdtnkN4QWSu/dal3kkr2M5JoGrSzU1c+mUPeQZ/UkNXN3qgRvU0LvMjWV0
9nAAc6py
=qiWo
-----END PGP SIGNATURE-----


?