[PATCH 20/25] gnu: Add go-golang-org-x-vuln.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:45
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-21-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-golang-org-x-vuln): New variable.
---
gnu/packages/golang.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f135b2717f..26cd636c64 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3007,6 +3007,20 @@ (define-public govulncheck
following:")
(license license:bsd-3)))
+(define-public go-golang-org-x-vuln
+ (package
+ (inherit govulncheck)
+ (name "go-golang-org-x-vuln")
+ (arguments
+ `(#:import-path "golang.org/x/vuln"
+ #:tests? #f
+ #:install-source? #t
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs (package-inputs govulncheck))
+ (native-inputs '())
+ (inputs '())))
+
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60919] [PATCH 20/25] gnu: Add go-golang-org-x-vuln.
CQBUYO71TSGG.3ELAEBLOM08S3@guix-framework
* gnu/packages/golang.scm (go-golang-org-x-vuln): New variable.

SGTM.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhiRMACgkQ7ImHg/nq
I21l1gv/Xc+m8KCgI7EUHVtuIGTg9iK7+Iyy7ZdeW5xhQLzxWqNIoqvIGkdL8V5Y
ik63wo83aVrWcCTyEaP0AWZZJZhi3PfqxFRIvuKByiCFOsqW6EoZF/DhOHBv6VRi
PZTyyJvyLrmc3MdcGA9aBg9TOaIyRiDq+h5BfoVo7pyFEj/OmuSBMWByA/liBUna
rdy1n8N2KOzG7SY3xow6rCFqzTXD5PLRm/UkEZF5eM6dRFRzbkAAL00uHRAmE5f8
VPqc6coFdDxRDh6AqEIPmq3BanzfIFouLoKLrIIpS7vFDFuNIX17aPPgFSU0ovwg
HqyHjyP5RhgMRQ6I/HRJkBPH1qvbCHtsIMh09iblfqcqCShm9sWMs0eAIKfGM4K5
cEMKhcwP47vBiOSvoIfLDDMB8vtbPELB7ngIRTLyvazWUM2oP1dBkJyuqeo+CiS/
9GvBJLGf7cphccVoTSqsOzNgiE0XZeqB61gEeTCw+6KO8CNa30quANMw2Waz8Oey
/TYcx5zo
=Bqzo
-----END PGP SIGNATURE-----


?