[PATCH 36/41] gnu: Add go-gopkg-in-tomb-v1.

(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220803120439.5108-36-paren@disroot.org
* gnu/packages/golang.scm (go-gopkg-in-tomb-v1): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ee01b9ea1..da7b983475 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10851,3 +10851,29 @@ (define-public go-github-com-onsi-gomega
(description
"Gomega is the preferred matcher library for the Ginkgo test framework.")
(license license:expat)))
+
+(define-public go-gopkg-in-tomb-v1
+ (package
+ (inherit go-gopkg.in-tomb.v2)
+ (name "go-gopkg-in-tomb-v1")
+ (version "1.0.0-20141024135613-dd632973f1e7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/tomb.v1")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lqmq1ag7s4b3gc3ddvr792c5xb5k6sfn0cchr3i2s7f1c231zjv"))))
+ (arguments
+ (list #:import-path "gopkg.in/tomb.v1"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda* (#:key import-path #:allow-other-keys)
+ (substitute* (string-append "src/" import-path
+ "/tomb_test.go")
+ (("t.Fatalf\\(`Killf\\(\"BO%s")
+ "t.Fatalf(`Killf(\"BO%%s")))))))
+ (home-page "https://gopkg.in/tomb.v1")))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?