(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
* gnu/packages/golang.scm (go-gopkg-in-tomb-v1): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ee01b9ea1..da7b983475 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10851,3 +10851,29 @@ (define-public go-github-com-onsi-gomega
(description
"Gomega is the preferred matcher library for the Ginkgo test framework.")
(license license:expat)))
+
+(define-public go-gopkg-in-tomb-v1
+ (package
+ (inherit go-gopkg.in-tomb.v2)
+ (name "go-gopkg-in-tomb-v1")
+ (version "1.0.0-20141024135613-dd632973f1e7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/tomb.v1")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lqmq1ag7s4b3gc3ddvr792c5xb5k6sfn0cchr3i2s7f1c231zjv"))))
+ (arguments
+ (list #:import-path "gopkg.in/tomb.v1"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda* (#:key import-path #:allow-other-keys)
+ (substitute* (string-append "src/" import-path
+ "/tomb_test.go")
+ (("t.Fatalf\\(`Killf\\(\"BO%s")
+ "t.Fatalf(`Killf(\"BO%%s")))))))
+ (home-page "https://gopkg.in/tomb.v1")))
--
2.37.1