[PATCH 28/41] gnu: Add go-github-com-arran4-golang-ical.

(
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220803120439.5108-28-paren@disroot.org
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-arran4-golang-ical): New
variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 41bbb3c228..6dda84e855 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10639,3 +10639,31 @@ (define-public go-github-com-niemeyer-pretty
useful during debugging, to avoid wrapping long output lines in the
terminal.")
(license license:expat)))
+
+(define-public go-github-com-arran4-golang-ical
+ (package
+ (name "go-github-com-arran4-golang-ical")
+ (version "0.0.0-20220517104411-fd89fefb0182")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arran4/golang-ical")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bxs0b5yg26liiifc0cc41l307r0wc93hp8iygv8dgpc60yzncaw"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/arran4/golang-ical"))
+ (propagated-inputs (list go-gopkg-in-yaml-v3
+ go-gopkg-in-check-v1
+ go-github-com-stretchr-testify
+ go-github-com-niemeyer-pretty
+ go-github-com-kr-text
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/arran4/golang-ical")
+ (synopsis "Handle iCalenders in Go")
+ (description
+ "The ical package provides an ICS/iCalender parser and serialiser for Go.")
+ (license license:asl2.0)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?