(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
From: "(unmatched-parenthesis" <paren@disroot.org>
* gnu/packages/golang.scm (go-github-com-protonmail-go-crypto): New variable.
---
gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0550aa1a0e..1616d19c9d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10521,3 +10521,35 @@ (define-public go-github-com-emersion-go-imap-sortthread
"The sortthread package implements message sorting and threading for
@code{go-github-com-emersion-go-imap}.")
(license license:expat)))
+
+(define-public go-github-com-protonmail-go-crypto
+ (package
+ (name "go-github-com-protonmail-go-crypto")
+ (version "0.0.0-20220623141421-5afb4c282135")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ProtonMail/go-crypto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05qxdbn8wdk901z5kw2r3jdrag58nxlcsy0p8xd6rq0d71sw94wy"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/ProtonMail/go-crypto"
+ #:tests? #f ; Source-only package.
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (propagated-inputs (list go-golang-org-x-crypto))
+ (home-page "https://github.com/ProtonMail/go-crypto")
+ (synopsis "Fork of golang.org/x/crypto with up-to-date OpenPGP
+implementation")
+ (description
+ "The crypto package provides cryptography for Go. This version of the
+package is a fork that adds a more up-to-date OpenPGP implementation. It
+is completely backwards compatible with
+@url{golang.org/x/crypto,the official package}.")
+ (license license:bsd-3)))
--
2.37.1