[PATCH 01/41] gnu: Add go-github-com-zenhack-go-notmuch.

(
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220803120439.5108-1-paren@disroot.org
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch): New
variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4756bcb249..2842c7f481 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -72,6 +72,7 @@ (define-module (gnu packages golang)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages mail)
#:use-module (gnu packages mp3)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
@@ -9911,3 +9912,30 @@ (define-public gopls
server implementation for the Go programming language. It provides
on-the-fly code linting, formatting, completion, and introspection for
Go code in text editors supporting LSP.")))
+
+(define-public go-github-com-zenhack-go-notmuch
+ (package
+ (name "go-github-com-zenhack-go-notmuch")
+ (version "0.0.0-20211022191430-4d57e8ad2a8b")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zenhack/go.notmuch")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j2s5smjf7pp7i72dw12sm9iz961y3cy8nkm7hmrg53f6wna57h9"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/zenhack/go.notmuch"
+ ;; XXX: Tests require you to download fixtures from the Internet.
+ ;; See <https://github.com/zenhack/go.notmuch/blob/master/Makefile>.
+ #:tests? #f))
+ (propagated-inputs (list notmuch))
+ (home-page "https://github.com/zenhack/go.notmuch")
+ (synopsis "Go bindings to libnotmuch")
+ (description
+ "The notmuch package provides a Go language binding to the notmuch
+email library.")
+ (license license:gpl3+)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
CLWE4I13HN3F.1J1GCLCLOO4CL@guix-aspire
Oops! I accidentally created an issue for each patch, and forgot
to mark these patches with v5. Anyway, this updates the aerc patchset
to version 0.11.0, hopefully the last update I'll need to do before
this is merged.

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?