(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
From: "(unmatched-parenthesis" <paren@disroot.org>
* gnu/packages/golang.scm (go-github-com-emersion-go-msgauth): New
variable.
---
gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ac67ba9a2e..a788a767e0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10790,3 +10790,33 @@ (define-public go-github-com-emersion-go-milter
"The milter package provides an interface to implement milter mail
filters in Go.")
(license license:bsd-2)))
+
+(define-public go-github-com-emersion-go-msgauth
+ (package
+ (name "go-github-com-emersion-go-msgauth")
+ (version "0.6.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-msgauth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ds8yr4cm9wigcxg1sxc2m0wmy4z9n6gws3mj50dmf2ayij69z9j"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/emersion/go-msgauth"
+ #:tests? #f ; Source-only package.
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (propagated-inputs (list go-golang-org-x-crypto
+ go-github-com-emersion-go-milter
+ go-github-com-emersion-go-message))
+ (home-page "https://github.com/emersion/go-msgauth")
+ (synopsis "Email authentication for Go")
+ (description
+ "The msgauth package provides a Go library for authenticating emails.")
+ (license license:expat)))
--
2.37.1