(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
From: "(unmatched-parenthesis" <paren@disroot.org>
* gnu/packages/golang.scm (go-git-sr-ht--sircmpwn-getopt): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6dda84e855..bcd73c3c1b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10667,3 +10667,27 @@ (define-public go-github-com-arran4-golang-ical
(description
"The ical package provides an ICS/iCalender parser and serialiser for Go.")
(license license:asl2.0)))
+
+(define-public go-git-sr-ht--sircmpwn-getopt
+ (package
+ (name "go-git-sr-ht--sircmpwn-getopt")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/getopt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f9rammnmhaz21qkmz7qf76r8jlzi323g05ps3j7gwrxlw7442a6"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~sircmpwn/getopt"))
+ (propagated-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://git.sr.ht/~sircmpwn/getopt")
+ (synopsis "POSIX getopt for Go")
+ (description
+ "The getopt package is a POSIX-compatible implementation of getopt(3)
+for Go.")
+ (license license:bsd-3)))
--
2.37.1