[PATCH 35/41] gnu: Add go-github-com-onsi-gomega.

(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220803120439.5108-35-paren@disroot.org
* gnu/packages/golang.scm (go-github-com-onsi-gomega): New variable.
---
gnu/packages/golang.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a788a767e0..6ee01b9ea1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10820,3 +10820,34 @@ (define-public go-github-com-emersion-go-msgauth
(description
"The msgauth package provides a Go library for authenticating emails.")
(license license:expat)))
+
+(define-public go-github-com-onsi-gomega
+ (package
+ (name "go-github-com-onsi-gomega")
+ (version "1.19.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/onsi/gomega")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "092phwk97sk4sv0nbx5pfhqs6x3x1lnrjwyda1m6b6zwrfmq5c6i"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/onsi/gomega"
+ ;; Unless we disable the tests, we have a circular dependency on
+ ;; ginkgo/v2.
+ #:tests? #f))
+ (propagated-inputs (list go-github-com-golang-protobuf-proto
+ go-golang-org-x-net
+ go-golang-org-x-sys
+ go-golang-org-x-text
+ go-google-golang-org-protobuf
+ go-gopkg-in-yaml-v2))
+ (home-page "https://github.com/onsi/gomega")
+ (synopsis "Matcher library for Ginkgo")
+ (description
+ "Gomega is the preferred matcher library for the Ginkgo test framework.")
+ (license license:expat)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?