Preliminary untested patch!
* gnu/packages/qt.scm (qtwebkit): Remove variable.
(python-pyqt)[inputs]: Remove qtwebkit.
(python-pyqt-without-qtwebkit): Remove variable.
* gnu/packages/kde-frameworks.scm (kdewebkit): Remove variable.
* gnu/packages/engineering.scm (freecad)[inputs]: Remove qtwebkit.
* gnu/packages/fcitx5.scm (fcitx5-qt)[inputs]: Remove qtwebkit.
* gnu/packages/geo.scm (qgis): Remove qtwebkit.
* gnu/packages/image-viewers.scm (luminance-hdr)[inputs]: Remove qtwebkit.
* gnu/packages/kde-frameworks.scm (kdesignerplugin)[inputs]: Remove qtwebkit and kdewebkit.
* gnu/packages/kde-internet.scm (sonnet)[inputs]: Remove qtwebkit.
(ktorrent)[inputs]: Remove qtwebkit and kdewebkit.
(choqok)[inputs]: Remove kdewebkit.
* gnu/packages/kde-multimedia.scm (k3b)[inputs]: Remove qtwebkit.
* gnu/packages/kde-pim.scm (kmessagelib)[inputs]: Remove qtwebkit.
* gnu/packages/kde-pim.scm (libksysguard)[inputs]: Remove qtwebkit.
* gnu/packages/kde.scm (kdenlive)[inputs]: Likewise.
(kdevelop)[inputs]: Likewise.
* gnu/packages/messaging.scm (psi)[inputs]: Remove qtwebkit.
* gnu/packages/radio.scm (dream)[inputs]: Remove qtwebkit.
(gnuradio): Replace python-pyqt-without-qtwebkit with python-pyqt.
* gnu/packages/robotics.scm (aseba)[inputs]: Remove qtwebkit.
* gnu/packages/sync.scm (nextcloud-client)[inputs]: Remove qtwebkit.
(qsyncthingtray)[inputs]: Remove qtwebkit.
* gnu/packages/syndication.scm (quiterss)[inputs]: Remove qtwebkit.
* gnu/packages/tex.scm (texmaker)[inputs]: Remove qtwebkit.
* gnu/packages/video.scm (shotcut)[inputs]: Remove qtwebkit.
* gnu/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch,
gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch,
gnu/packages/patches/qtwebkit-fix-building-with-icu-68.patch,
gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch,
gnu/packages/patches/qtwebkit-pbutils-include.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
---
gnu/local.mk | 5 -
gnu/packages/engineering.scm | 1 -
gnu/packages/fcitx5.scm | 3 +-
gnu/packages/geo.scm | 1 -
gnu/packages/image-viewers.scm | 1 -
gnu/packages/kde-frameworks.scm | 34 ----
gnu/packages/kde-internet.scm | 4 -
gnu/packages/kde-multimedia.scm | 1 -
gnu/packages/kde-pim.scm | 1 -
gnu/packages/kde-plasma.scm | 1 -
gnu/packages/kde.scm | 2 -
gnu/packages/messaging.scm | 1 -
...qtwebkit-fix-building-with-bison-3.7.patch | 54 -------
...qtwebkit-fix-building-with-glib-2.68.patch | 21 ---
.../qtwebkit-fix-building-with-icu-68.patch | 152 ------------------
...twebkit-fix-building-with-python-3.9.patch | 35 ----
.../patches/qtwebkit-pbutils-include.patch | 15 --
gnu/packages/qt.scm | 93 -----------
gnu/packages/radio.scm | 2 -
gnu/packages/robotics.scm | 1 -
gnu/packages/sync.scm | 3 +-
gnu/packages/syndication.scm | 2 +-
gnu/packages/tex.scm | 2 +-
gnu/packages/video.scm | 1 -
24 files changed, 4 insertions(+), 432 deletions(-)
delete mode 100644 gnu/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch
delete mode 100644 gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch
delete mode 100644 gnu/packages/patches/qtwebkit-fix-building-with-icu-68.patch
delete mode 100644 gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch
delete mode 100644 gnu/packages/patches/qtwebkit-pbutils-include.patch
Toggle diff (265 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 0eed20e7af..ea0bde5313 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1731,11 +1731,6 @@ dist_patch_DATA = \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
- %D%/packages/patches/qtwebkit-pbutils-include.patch \
- %D%/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch \
- %D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
- %D%/packages/patches/qtwebkit-fix-building-with-icu-68.patch \
- %D%/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch \
%D%/packages/patches/ragel-char-signedness.patch \
%D%/packages/patches/randomjungle-disable-static-build.patch \
%D%/packages/patches/range-v3-build-with-gcc10.patch \
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d27ad677bb..ac695a2c73 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2485,7 +2485,6 @@ (define-public freecad
python-wrapper
qtbase-5
qtsvg
- qtwebkit
qtx11extras
qtxmlpatterns
sqlite
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 92fc0ea171..82a0192359 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -304,8 +304,7 @@ (define-public fcitx5-chinese-addons
("libpthread-stubs" ,libpthread-stubs)
("opencc" ,opencc)
("qtbase" ,qtbase-5)
- ("fcitx5-qt" ,fcitx5-qt)
- ("qtwebkit" ,qtwebkit)))
+ ("fcitx5-qt" ,fcitx5-qt)))
(native-inputs
(list extra-cmake-modules pkg-config))
(outputs '("out" "gui"))
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index fbe63ce184..225f5e2c2b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2485,7 +2485,6 @@ (define-public qgis
qtlocation
qtserialport
qtsvg
- qtwebkit
qwt
;;("saga" ,saga)
sqlite))
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index b61a79370d..2077e462dc 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -607,7 +607,6 @@ (define-public luminance-hdr
`(("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtsvg" ,qtsvg)
- ("qtwebkit" ,qtwebkit)
("boost" ,boost)
("eigen" ,eigen)
;; ("gtest" ,gtest)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 65937f8970..c49e9c5602 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2359,10 +2359,8 @@ (define-public kdesignerplugin
kio
kplotting
ktextwidgets
- kdewebkit
kwidgetsaddons
kxmlgui
- qtwebkit
sonnet))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Integrating KDE frameworks widgets with Qt Designer")
@@ -2399,38 +2397,6 @@ (define-public kdesu
with su and ssh respectively.")
(license license:lgpl2.1+)))
-(define-public kdewebkit
- (package
- (name "kdewebkit")
- (version "5.70.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/portingAids/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0y9ja3znkvzdbjfs91dwr4cmvl9fk97zpz2lkf0f9zhm2nw6q008"))))
- (build-system cmake-build-system)
- (native-inputs
- (list extra-cmake-modules qttools))
- (inputs
- (list kconfig
- kcoreaddons
- kio
- kjobwidgets
- kparts
- kservice
- kwallet
- qtbase-5
- qtwebkit))
- (home-page "https://community.kde.org/Frameworks")
- (synopsis "KDE Integration for QtWebKit")
- (description "This library provides KDE integration of the HTML rendering
-engine WebKit via QtWebKit.")
- (license license:lgpl2.1+)))
-
(define-public kemoticons
(package
(name "kemoticons")
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index 4e08bd5337..3e1cc45d88 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -70,7 +70,6 @@ (define-public choqok
kcmutils
kconfigwidgets
kcoreaddons
- kdewebkit
kemoticons
kglobalaccel
kguiaddons
@@ -90,7 +89,6 @@ (define-public choqok
qoauth
qtbase-5
qtnetworkauth
- qtwebkit
sonnet))
(home-page "https://kde.org/applications/internet/org.kde.choqok")
(synopsis "Micro-Blogging Client")
@@ -385,7 +383,6 @@ (define-public ktorrent
kcoreaddons
kcrash
kdbusaddons
- kdewebkit
kdnssd
ki18n
kiconthemes
@@ -405,7 +402,6 @@ (define-public ktorrent
phonon
qtbase-5
qtscript
- qtwebkit
solid
syndication
taglib))
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index e7a2b943e0..4638298939 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -421,7 +421,6 @@ (define-public k3b
libvorbis
oxygen-icons ; default icon set
qtbase-5
- qtwebkit
shared-mime-info
solid
sox
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index b17b18bd12..40abfdd899 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1325,7 +1325,6 @@ (define-public kmessagelib
qtdeclarative
qtwebchannel
qtwebengine
- qtwebkit
sonnet))
(arguments
`(#:tests? #f ;TODO many test fail for quite different reasons
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5621d8ea35..1eaff4f69b 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -251,7 +251,6 @@ (define-public libksysguard
("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtscript" ,qtscript)
- ("qtwebkit" ,qtwebkit)
("qtx11extras" ,qtx11extras)
("plasma" ,plasma-framework)
("zlib" ,zlib)))
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 8dfcba1388..a8b584d8ec 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -264,7 +264,6 @@ (define-public kdenlive
qtquickcontrols2
qtscript
qtsvg
- qtwebkit
shared-mime-info))
(arguments
;; XXX: there is a single test that spawns other tests and
@@ -343,7 +342,6 @@ (define-public kdevelop
("qtdeclarative" ,qtdeclarative)
("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
- ("qtwebkit" ,qtwebkit)
("threadweaver" ,threadweaver)
;; recommendes
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2fe0d35a10..56f8fbd905 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -227,7 +227,6 @@ (define-public psi
("qtbase" ,qtbase-5)
("qtmultimedia" ,qtmultimedia)
("qtsvg" ,qtsvg)
- ("qtwebkit" ,qtwebkit)
("qtx11extras" ,qtx11extras)
("x11" ,libx11)
("xext" ,libxext)
diff --git a/gnu/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch b/gnu/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch
deleted file mode 100644
index ddaf8e2849..0000000000
--- a/gnu/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Fix build with Bison 3.7
-
-https://bugs.gentoo.org/736499
-
-Patch copied from upstream source repository:
-
-https://github.com/qtwebkit/qtwebkit/commit/d92b11fea65364fefa700249bd3340e0cd4c5b31
-
-From d92b11fea65364fefa700249bd3340e0cd4c5b31 Mon Sep 17 00:00:00 2001
-From: Dmitry Shachnev <mitya57@gmail.com>
-Date: Tue, 4 Aug 2020 21:04:06 +0300
-Subject: [PATCH] Let Bison generate the header directly, to fix build with
- Bison 3.7
-
-Starting with Bison 3.7, the generated C++ file #include's the header
-by default, instead of duplicating it. So we should not delete it.
-
-Remove the code to add #ifdef guards to the header, since Bison adds
-them itself since version 2.6.3.
----
- Source/WebCore/css/makegrammar.pl | 21 +--------------------
- 1 file changed, 1 insertion(+), 20 deletions(-)
-
-diff --git a/Source/WebCore/css/makegrammar.pl b/Source/WebCore/css/makegrammar.pl
-index 5d63b08102eb5..9435701c70612 100644
---- a/Source/WebCore/css/makegrammar.pl
-+++ b/Source/WebCore/css/makegrammar.pl
-@@ -73,25 +73,6 @@
- }
-
- my $fileBase = File::Spec->join($outputDir, $filename);
--my @bisonCommand = ($bison, "-d", "-p", $symbolsPrefix, $grammarFilePath, "-o", "$fileBase.cpp");
-+my @bisonCommand = ($bison, "--defines=$fileBase.h", "-p", $symbolsPrefix, $grammarFilePath, "-o", "$fileBase.cpp");
- push @bisonCommand, "--no-lines" if $^O eq "MSWin32"; # Work around bug in bison >= 3.0 on Windows where it puts backslashes into #line directives.
- system(@bisonCommand) == 0 or die;
--
--open HEADER, ">$fileBase.h" or die;
--print HEADER << "EOF";
--#ifndef CSSGRAMMAR_H
--#define CSSGRAMMAR_H
--EOF
--
--open HPP, "<$fileBase.cpp.h" or open HPP, "<$fileBase.hpp" or die;
--while (<HPP>) {
-- print HEADER;
--}
--close HPP;
--
--print HEADER "#endif\n";
--close HEADER;
--
--unlink("$fileBase.cpp.h");
--unlink("$fileBase.hpp");
--
Toggle diff (23 lines)
diff --git a/gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch b/gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch
deleted file mode 100644
index 63840f4bbc..0000000000
--- a/gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix building with glib 2.68:
-
-https://github.com/qtwebkit/qtwebkit/issues/1057
-
-Patch copied from upstream pull request:
-
-https://github.com/qtwebkit/qtwebkit/pull/1058/commits/5b698ba3faffd4e198a45be9fe74f53307395e4b
-
-diff -aurN qtwebkit-5.212.0-alpha4/Source/WTF/wtf/glib/GRefPtr.h qtwebkit-5.212.0-alpha4-mod/Source/WTF/wtf/glib/GRefPtr.h
---- qtwebkit-5.212.0-alpha4/Source/WTF/wtf/glib/GRefPtr.h 2020-03-04 18:16:37.000000000 +0100
-+++ qtwebkit-5.212.0-alpha4-mod/Source/WTF/wtf/glib/GRefPtr.h 2021-04-05 06:58:44.763328636 +0200
-@@ -29,9 +29,6 @@
- #include <wtf/RefPtr.h>
- #include <algorithm>
-
--extern "C" void g_object_unref(gpointer);
--extern "C" gpointer g_object_ref_sink(gpointer);
--
- namespace WTF {
-
- enum GRefPtrAdoptType { GRefPtrAdopt };
Toggle diff (112 lines)
diff --git a/gnu/packages/patches/qtwebkit-fix-building-with-icu-68.patch b/gnu/packages/patches/qtwebkit-fix-building-with-icu-68.patch
deleted file mode 100644
index acbfc4c4c8..0000000000
--- a/gnu/packages/patches/qtwebkit-fix-building-with-icu-68.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-Fix building with ICU > 68.
-
-https://bugs.gentoo.org/753260
-
-Patch adapted from Gentoo:
-
-https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=335f29d266c5b169ff1e781f9851a3a203f3198c
-
-From 335f29d266c5b169ff1e781f9851a3a203f3198c Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 6 Nov 2020 09:22:15 +0100
-Subject: dev-qt/qtwebkit: Fix build with ICU-68
-
-Thanks-to: Lars Wendler <polynomial-c@gentoo.org>
-Closes: https://bugs.gentoo.org/753260
-Package-Manager: Portage-3.0.9, Repoman-3.0.2
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- .../qtwebkit-5.212.0_pre20200309-icu-68.patch | 120 +++++++++++++++++++++
- 1 file changed, 120 insertions(+)
- create mode 100644 dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20200309-icu-68.patch
-
-(limited to 'dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20200309-icu-68.patch')
-
-diff --git a/Source/WebCore/platform/text/TextCodecICU.cpp b/Source/WebCore/platform/text/TextCodecICU.cpp
-index dd6ff06..e0f4bd7 100644
---- a/Source/WebCore/platform/text/TextCodecICU.cpp
-+++ b/Source/WebCore/platform/text/TextCodecICU.cpp
-@@ -308,7 +308,7 @@ void TextCodecICU::createICUConverter() const
- m_converterICU = ucnv_open(m_canonicalConverterName, &err);
- ASSERT(U_SUCCESS(err));
- if (m_converterICU)
-- ucnv_setFallback(m_converterICU, TRUE);
-+ ucnv_setFallback(m_converterICU, true);
- }
-
- int TextCodecICU::decodeToBuffer(UChar* target, UChar* targetLimit, const char*& source, const char* sourceLimit, int32_t* offsets, bool flush, UErrorCode& err)
-diff --git a/Source/WebCore/platform/text/icu/UTextProvider.h b/Source/WebCore/platform/text/icu/UTextProvider.h
-index c254fc4..6d1e1cb 100644
---- a/Source/WebCore/platform/text/icu/UTextProvider.h
-+++ b/Source/WebCore/platform/text/icu/UTextProvider.h
-@@ -80,12 +80,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text, int64_t nativeIndex, int
- // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
- ASSERT(offset < std::numeric_limits<int32_t>::max());
- text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
-- isAccessible = TRUE;
-+ isAccessible = true;
- return true;
- }
- if (nativeIndex >= nativeLength && text->chunkNativeLimit == nativeLength) {
- text->chunkOffset = text->chunkLength;
-- isAccessible = FALSE;
-+ isAccessible = false;
- return true;
- }
- } else {
-@@ -94,12 +94,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text, int64_t nativeIndex, int
- // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
- ASSERT(offset < std::numeric_limits<int32_t>::max());
- text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
-- isAccessible = TRUE;
-+ isAccessible = true;
- return true;
- }
- if (nativeIndex <= 0 && !text->chunkNativeStart) {
- text->chunkOffset = 0;
-- isAccessible = FALSE;
-+ isAccessible = false;
- return true;
- }
- }
-diff --git a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
-index cd6852c..6a864b1 100644
---- a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
-+++ b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
-@@ -100,23 +100,23 @@ static UBool uTextLatin1Access(UText* uText, int64_t index, UBool forward)
- if (index < uText->chunkNativeLimit && index >= uText->chunkNativeStart) {
- // Already inside the buffer. Set the new offset.
- uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
-- return TRUE;
-+ return true;
- }
- if (index >= length && uText->chunkNativeLimit == length) {
- // Off the end of the buffer, but we can't get it.
- uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
-- return FALSE;
-+ return false;
- }
- } else {
- if (index <= uText->chunkNativeLimit && index > uText->chunkNativeStart) {
- // Already inside the buffer. Set the new offset.
- uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
-- return TRUE;
-+ return true;
- }
- if (!index && !uText->chunkNativeStart) {
- // Already at the beginning; can't go any farther.
- uText->chunkOffset = 0;
-- return FALSE;
-+ return false;
- }
- }
-
-@@ -144,7 +144,7 @@ static UBool uTextLatin1Access(UText* uText, int64_t index, UBool forward)
-
- uText