[PATCH] gnu: QGIS: Build without QtWebKit.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 24 Jan 2022 21:15
(address . guix-patches@gnu.org)(address . glv@posteo.net)
d27a8c912d218a917989416d4181b999c37a6784.1643055300.git.leo@famulari.name
See https://issues.guix.gnu.org/53289 for more information about this change.

With this change, the build fails due to some tests timing out.

I don't use QGIS, so it's not easy for me to understand the problem or
if it's okay to add tese tests to the long list of disabled tests. I
also could not find any online discussion about these tests timing out.

* gnu/packages/geo.scm (qgis)[inputs]: Remove qtwebkit.
[arguments]: Pass "-DWITH_QTWEBKIT=NO" to #:configure-flags.
---
gnu/packages/geo.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 287b157b60..05591b7ce7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2274,6 +2274,8 @@ (define-public qgis
#:imported-modules (,@%cmake-build-system-modules
(guix build python-build-system)
(guix build qt-utils))
+ #:configure-flags
+ '("-DWITH_QTWEBKIT=NO")
#:phases
(modify-phases %standard-phases
;; Configure correct path to PyQt5 SIP directory
@@ -2490,7 +2492,6 @@ (define-public qgis
qtlocation
qtserialport
qtsvg
- qtwebkit
qwt
;;("saga" ,saga)
sqlite))
--
2.34.0
L
L
Leo Famulari wrote on 24 Jan 2022 21:18
(no subject)
(address . control@debbugs.gnu.org)
Ye8JrF9ILLnEvTJO@jasmine.lan
block 53289 with 53512
G
G
Guillaume Le Vaillant wrote on 25 Jan 2022 12:05
Re: [PATCH] gnu: QGIS: Build without QtWebKit.
(name . Leo Famulari)(address . leo@famulari.name)(address . guix-patches@gnu.org)
87h79sdq2a.fsf@kitej
Leo Famulari <leo@famulari.name> skribis:

Toggle quote (36 lines)
> See https://issues.guix.gnu.org/53289 for more information about this change.
>
> With this change, the build fails due to some tests timing out.
>
> I don't use QGIS, so it's not easy for me to understand the problem or
> if it's okay to add tese tests to the long list of disabled tests. I
> also could not find any online discussion about these tests timing out.
>
> * gnu/packages/geo.scm (qgis)[inputs]: Remove qtwebkit.
> [arguments]: Pass "-DWITH_QTWEBKIT=NO" to #:configure-flags.
> ---
> gnu/packages/geo.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index 287b157b60..05591b7ce7 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2274,6 +2274,8 @@ (define-public qgis
> #:imported-modules (,@%cmake-build-system-modules
> (guix build python-build-system)
> (guix build qt-utils))
> + #:configure-flags
> + '("-DWITH_QTWEBKIT=NO")
> #:phases
> (modify-phases %standard-phases
> ;; Configure correct path to PyQt5 SIP directory
> @@ -2490,7 +2492,6 @@ (define-public qgis
> qtlocation
> qtserialport
> qtsvg
> - qtwebkit
> qwt
> ;;("saga" ,saga)
> sqlite))

It looks like the failing tests are trying to do some HTML rendering,
which requires QtWebKit I suppose. But why is the test suite trying to
run these tests if QtWebKit is explicitly disabled?

The 'check' phase currently doesn't take the 'tests?' keyword parameter
into consideration. Maybe you could add that to your patch.

After disabling the tests, I tried a few things, like loading some
OpenStreetMap data from a database and making a map with it, and
I didn't see any issue. So I think you can add the failing tests to the
list of disabled tests.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYe/bzQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/jNwD+P9ZhaYYJTiWuO5KLjkAkIT79+IzuUDMyR4h8
hd3DqvYBAJI6IVHxoVJoV5YhBTm1KTKgom/NR71gRtf5GWhJYDZt
=Jweb
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 25 Jan 2022 19:40
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . guix-patches@gnu.org)
YfBEGR0zwXyfgLB0@jasmine.lan
On Tue, Jan 25, 2022 at 11:05:50AM +0000, Guillaume Le Vaillant wrote:
Toggle quote (4 lines)
> It looks like the failing tests are trying to do some HTML rendering,
> which requires QtWebKit I suppose. But why is the test suite trying to
> run these tests if QtWebKit is explicitly disabled?

That is indeed the question. I'd guess that using QGIS without QtWebKit
is not well exercised upstream.

Toggle quote (3 lines)
> The 'check' phase currently doesn't take the 'tests?' keyword parameter
> into consideration. Maybe you could add that to your patch.

Sure, thanks for noticing that.

Toggle quote (5 lines)
> After disabling the tests, I tried a few things, like loading some
> OpenStreetMap data from a database and making a map with it, and
> I didn't see any issue. So I think you can add the failing tests to the
> list of disabled tests.

Okay, thanks for checking. I'll test a revised patch and push once it
builds.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmHwRBkACgkQJkb6MLrK
fwgNkA//XdY8O5qWSjVAS41f0LMwEm6Wkgkl5pC/rc0bxCilLeneJvSj2FrJxgkq
z15P1aPhbt2und6o3kdYyol9R0wH56Df0Dyz9WDVu2Um0G9BmRvqNsfe2cSNBJE1
Y7Hce25W0qC5mO7x9UN0791ungsDVLJbgq46k1m8e7Roj34hZYhYvRgsiOR4tjmY
bpsgwbJlUpUUB98hqskZWt2+VrwI97El/XzSZxsT8ROk9ej2pqR4+ad1acEZP5sU
5i0rDjhJKhyvSST7w6SobtlqpN12/XeRSBZS/OiHdrQIzQ45VJe2+hVsTW9px95K
s+H8Gat2oj82Rcd7MqDRReS06S7Wj/o37YGu5Tp38/XNF3y8yF0kYIZEoTLX57gO
JJxq74XimQVzl8WqIKkHXQXQavHgxE0pPgHw3AxV383X2xPV5p+kcKZ62SBY04oi
0gKUeHg2cf13aQLm2DKHpV8dSHmYYAFFscIRg73cRSqZVZ7Bs+N41wL8H213qoXo
Z+tHwG1OEfleIa8ajdTiuCo+PE7bysf8gftJ1t/dcTo68KAUmKvqr7S00q+kdme1
r6+U7MMQiZEhST9FTNrvUZRoZJTHkVn7TvaZWHvUCb7LUPBF+PUznQRNxQOHLSgV
3rVkr6Bfclye/jO3QQecYaPbGFqaeTlSL9ORHe9SuS/mia+6iu4=
=n+E/
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 25 Jan 2022 21:11
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 53512-done@debbugs.gnu.org)
YfBZgSRuRpprAtLc@jasmine.lan
On Tue, Jan 25, 2022 at 01:40:25PM -0500, Leo Famulari wrote:
Toggle quote (3 lines)
> Okay, thanks for checking. I'll test a revised patch and push once it
> builds.

Pushed as 4235c6ee92b5c8875343c675c8d841eaa9f40d4c.

I did forget to adjust the indentation of the test phase... oh well.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmHwWYEACgkQJkb6MLrK
fwgBgw/7BXQCUHLKPDkIVwhdCQIE7O5nAxKyJ1lBN1r7JJsK/FYCsXvjhfho/CZc
9RsPS/JsvphbfLPFd8SMnh3OyOqJgIcpacu7okqyIfQvfBCJ1sPeP8j7l7P7y14x
07YxO4EjXDPF/GhDN71mFh6CwvoBoKzpZuZsrdm0IoxEbuDA4s1mG4kX9TH3zUDE
li5AGJ/1HfSmYf5IxzvOTW//Bg66gM8SartPUnDB2rHOjQA4ixAwfTHMMB+A9y27
c/OFEwbHc5b7+UngDPnR0yxCpgH1w5jFYV93Ml1TEYEuI4JFcsTWcQlE+JeFOise
YfcN8r6Qf50HzE12az/2Vh7LVcErjjlF9SZ2w07fiCrn2gygIfaad+2d2MG49xAc
nsXokURn+pypfcptoH1DVxCGi6gIXvDYKapG57imr+wSERb3YX48mruV6erW+dIC
cEp7XxADilatZ89MUd+U3Vnk0mppnPKN8m4I5Bcnxklq51N25xeBOC0GrX4Pc+bQ
XA795Zg4wyM4rLQqYmLW2BUjHp06koY0wUGkKKvd/8uBbPmiqM/T5OMw7ajyPC0p
UIx2Rkd6ENwYF5JGQsOe+rTgz3KyMlB8snbNbaFMwo7HhcHx5ZDZVx41KhOORCnO
lQR3uTZqDXaaAJrVCoUTVwQFUdQjDhce5mAx51XHvc2uZVL4kLs=
=x0lM
-----END PGP SIGNATURE-----


Closed
?