[PATCH] gnu: python-poppler-qt5: Remove transitive dependency on QtWebkit.

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 14 Feb 2023 22:33
(address . guix-patches@gnu.org)
41db8651ddc9ecb200a2e661fb9d43593a70dd3a.1676410429.git.leo@famulari.name
This is required for https://issues.guix.gnu.org/53289.

* gnu/packages/pdf.scm (python-poppler-qt5)[inputs]: Replace python-pyqt with
python-pyqt-without-qtwebkit.
[arguments]: Adjust accordingly.
---
gnu/packages/pdf.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 864c23b0d2..478977d8c5 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -373,12 +373,12 @@ (define-public python-poppler-qt5
;; installation phase.
((@@ (guix build python-build-system) call-setuppy)
"build_ext" (list (string-append "--pyqt-sip-dir="
- (assoc-ref inputs "python-pyqt")
+ (assoc-ref inputs "python-pyqt-without-qtwebkit")
"/share/sip")) #t))))))
(native-inputs
(list pkg-config))
(inputs
- (list python-sip-4 python-pyqt poppler-qt5 qtbase-5))
+ (list python-sip-4 python-pyqt-without-qtwebkit poppler-qt5 qtbase-5))
(home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
--
2.39.1
L
L
Leo Famulari wrote on 14 Feb 2023 22:34
(no subject)
(address . control@debbugs.gnu.org)
Y+v+ZPaBQUxodrPN@jasmine.lan
block 53289 with 61515
L
L
Leo Famulari wrote on 17 Feb 2023 20:07
Re: [PATCH] gnu: python-poppler-qt5: Remove transitive dependency on QtWebkit.
(address . 61515-done@debbugs.gnu.org)
Y+/QZ20zgS67gVAg@jasmine.lan
I'm closing this patch because it is superseded by
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61515@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61515
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch