(address . guix-patches@gnu.org)
This is required for https://issues.guix.gnu.org/53289.
* gnu/packages/pdf.scm (python-poppler-qt5)[inputs]: Replace python-pyqt with
python-pyqt-without-qtwebkit.
[arguments]: Adjust accordingly.
---
gnu/packages/pdf.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (21 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 864c23b0d2..478977d8c5 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -373,12 +373,12 @@ (define-public python-poppler-qt5
;; installation phase.
((@@ (guix build python-build-system) call-setuppy)
"build_ext" (list (string-append "--pyqt-sip-dir="
- (assoc-ref inputs "python-pyqt")
+ (assoc-ref inputs "python-pyqt-without-qtwebkit")
"/share/sip")) #t))))))
(native-inputs
(list pkg-config))
(inputs
- (list python-sip-4 python-pyqt poppler-qt5 qtbase-5))
+ (list python-sip-4 python-pyqt-without-qtwebkit poppler-qt5 qtbase-5))
(home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
--
2.39.1