[PATCH] gnu: Remove psi.
(address . guix-patches@gnu.org)
This package requires QtWebKit, which is being removed from Guix.
See https://issues.guix.gnu.org/53289 for more information.
* gnu/packages/messaging.scm (psi): Remove variable.
---
gnu/packages/messaging.scm | 56 --------------------------------------
1 file changed, 56 deletions(-)
Toggle diff (69 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3027d56907..231ee1c5d3 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -193,62 +193,6 @@ (define-public omemo-wget
XMPP-based sessions.")
(license license:lgpl3+)))
-(define-public psi
- (package
- (name "psi")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/psi/Psi/"
- version "/psi-" version ".tar.xz"))
- (modules '((guix build utils)))
- (snippet
- `(begin
- (delete-file-recursively "3rdparty")))
- (sha256
- (base32 "1dxmm1d1zr0pfs51lba732ipm6hm2357jlfb934lvarzsh7karri"))))
- (build-system qt-build-system)
- (arguments
- `(#:tests? #f ; No target
- #:configure-flags
- (list
- "-DUSE_ENCHANT=ON"
- "-DUSE_CCACHE=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-cmake
- (lambda _
- (substitute* "cmake/modules/FindHunspell.cmake"
- (("hunspell-1.6")
- "hunspell-1.7"))
- #t)))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("ruby" ,ruby)))
- (inputs
- `(("aspell" ,aspell)
- ("enchant" ,enchant-1.6)
- ("hunspell" ,hunspell)
- ("libidn" ,libidn)
- ("qca" ,qca)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia-5" ,qtmultimedia-5)
- ("qtsvg-5" ,qtsvg-5)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("x11" ,libx11)
- ("xext" ,libxext)
- ("xcb" ,libxcb)
- ("zlib" ,zlib)))
- (synopsis "Qt-based XMPP Client")
- (description "Psi is a capable XMPP client aimed at experienced users.
-Its design goals are simplicity and stability.")
- (home-page "https://psi-im.org")
- (license license:gpl2+)))
-
(define-public libgnt
(package
(name "libgnt")
--
2.39.1