Replace psi with psi-plus

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 14 Feb 2023 22:52
[PATCH] gnu: Remove psi.
(address . guix-patches@gnu.org)
c3da4ef067d2a174ef4f690691ec7a8d20bae324.1676411565.git.leo@famulari.name
This package requires QtWebKit, which is being removed from Guix.

See https://issues.guix.gnu.org/53289 for more information.

* gnu/packages/messaging.scm (psi): Remove variable.
---
gnu/packages/messaging.scm | 56 --------------------------------------
1 file changed, 56 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3027d56907..231ee1c5d3 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -193,62 +193,6 @@ (define-public omemo-wget
XMPP-based sessions.")
(license license:lgpl3+)))
-(define-public psi
- (package
- (name "psi")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/psi/Psi/"
- version "/psi-" version ".tar.xz"))
- (modules '((guix build utils)))
- (snippet
- `(begin
- (delete-file-recursively "3rdparty")))
- (sha256
- (base32 "1dxmm1d1zr0pfs51lba732ipm6hm2357jlfb934lvarzsh7karri"))))
- (build-system qt-build-system)
- (arguments
- `(#:tests? #f ; No target
- #:configure-flags
- (list
- "-DUSE_ENCHANT=ON"
- "-DUSE_CCACHE=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-cmake
- (lambda _
- (substitute* "cmake/modules/FindHunspell.cmake"
- (("hunspell-1.6")
- "hunspell-1.7"))
- #t)))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("ruby" ,ruby)))
- (inputs
- `(("aspell" ,aspell)
- ("enchant" ,enchant-1.6)
- ("hunspell" ,hunspell)
- ("libidn" ,libidn)
- ("qca" ,qca)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia-5" ,qtmultimedia-5)
- ("qtsvg-5" ,qtsvg-5)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("x11" ,libx11)
- ("xext" ,libxext)
- ("xcb" ,libxcb)
- ("zlib" ,zlib)))
- (synopsis "Qt-based XMPP Client")
- (description "Psi is a capable XMPP client aimed at experienced users.
-Its design goals are simplicity and stability.")
- (home-page "https://psi-im.org")
- (license license:gpl2+)))
-
(define-public libgnt
(package
(name "libgnt")
--
2.39.1
L
L
Leo Famulari wrote on 14 Feb 2023 22:53
(no subject)
(address . control@debbugs.gnu.org)
Y+wCyqQjYInZ70PD@jasmine.lan
block 53289 with 61518
J
J
Jack Hill wrote on 14 Feb 2023 23:07
Re: [bug#61518] [PATCH] gnu: Remove psi.
(name . Leo Famulari)(address . leo@famulari.name)(address . 61518@debbugs.gnu.org)
dee13bfd-d28e-6d52-1e7e-4047ad271edf@jackhill.us
On Tue, 14 Feb 2023, Leo Famulari wrote:

Toggle quote (6 lines)
> This package requires QtWebKit, which is being removed from Guix.
>
> See <https://issues.guix.gnu.org/53289> for more information.
>
> * gnu/packages/messaging.scm (psi): Remove variable.

Should we deprecate it in favor of psi-plus?

Best,
Jack
L
L
Leo Famulari wrote on 14 Feb 2023 23:19
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 61518@debbugs.gnu.org)
Y+wI2Ee9ykh1E3oJ@jasmine.lan
On Tue, Feb 14, 2023 at 05:07:58PM -0500, Jack Hill wrote:
Toggle quote (10 lines)
> On Tue, 14 Feb 2023, Leo Famulari wrote:
>
> > This package requires QtWebKit, which is being removed from Guix.
> >
> > See <https://issues.guix.gnu.org/53289> for more information.
> >
> > * gnu/packages/messaging.scm (psi): Remove variable.
>
> Should we deprecate it in favor of psi-plus?

That's a good idea, thanks! Are you able to write a patch? :)
L
L
Leo Famulari wrote on 14 Feb 2023 23:31
[PATCH v2] gnu: psi: Replace with psi-plus.
(address . 61518@debbugs.gnu.org)
d935c2a6969a36891f97784e3cc2681ecac09f1b.1676413900.git.leo@famulari.name
This is required for https://issues.guix.gnu.org/53289.

* gnu/packages/messaging.scm (psi): Deprecate in favor of psi-plus.
---
gnu/packages/messaging.scm | 59 ++------------------------------------
1 file changed, 3 insertions(+), 56 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3027d56907..b6e7bc7cf1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -193,62 +193,6 @@ (define-public omemo-wget
XMPP-based sessions.")
(license license:lgpl3+)))
-(define-public psi
- (package
- (name "psi")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/psi/Psi/"
- version "/psi-" version ".tar.xz"))
- (modules '((guix build utils)))
- (snippet
- `(begin
- (delete-file-recursively "3rdparty")))
- (sha256
- (base32 "1dxmm1d1zr0pfs51lba732ipm6hm2357jlfb934lvarzsh7karri"))))
- (build-system qt-build-system)
- (arguments
- `(#:tests? #f ; No target
- #:configure-flags
- (list
- "-DUSE_ENCHANT=ON"
- "-DUSE_CCACHE=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-cmake
- (lambda _
- (substitute* "cmake/modules/FindHunspell.cmake"
- (("hunspell-1.6")
- "hunspell-1.7"))
- #t)))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("ruby" ,ruby)))
- (inputs
- `(("aspell" ,aspell)
- ("enchant" ,enchant-1.6)
- ("hunspell" ,hunspell)
- ("libidn" ,libidn)
- ("qca" ,qca)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia-5" ,qtmultimedia-5)
- ("qtsvg-5" ,qtsvg-5)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("x11" ,libx11)
- ("xext" ,libxext)
- ("xcb" ,libxcb)
- ("zlib" ,zlib)))
- (synopsis "Qt-based XMPP Client")
- (description "Psi is a capable XMPP client aimed at experienced users.
-Its design goals are simplicity and stability.")
- (home-page "https://psi-im.org")
- (license license:gpl2+)))
-
(define-public libgnt
(package
(name "libgnt")
@@ -3142,6 +3086,9 @@ (define-public psi-plus
designed for experienced users.")
(license license:gpl2+)))
+(define-public psi
+ (deprecated-package "psi" psi-plus))
+
(define-public python-zulip
(package
(name "python-zulip")
--
2.39.1
L
L
Leo Famulari wrote on 14 Feb 2023 23:31
(no subject)
(address . control@debbugs.gnu.org)
Y+wLsSHtc5g0YE7R@jasmine.lan
retitle 61518 Replace psi with psi-plus
L
L
Leo Famulari wrote on 17 Feb 2023 20:52
Re: Replace psi with psi-plus
(address . 61518-done@debbugs.gnu.org)
Y+/a5G4ehZbNoWbw@jasmine.lan
Pushed as 7eb3eec4dacc414a6680a97bc6ef38c1f76b947e
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61518@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61518
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch