Deprecate QSyncthingTray in favor of syncthing-gtk

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 25 Jan 2022 20:35
(address . guix-patches@gnu.org)
YfBRFOAW/KaWIWZK@jasmine.lan
This patch series deprecates QSyncthingTray in favor of Debian's fork of
syncthing-gtk.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmHwUREACgkQJkb6MLrK
fwimvA//QF0QNDEjNF2jOG5UVEWfuuuinjh4UbQSMw5Hv7rJe0Ep/Yac0XnCIVE+
KQJrZw5u8WOJvUc5k6hQ6ggwC0qkROqAIjtlkVQCdiS6nl/U+MpFs8UqXAZlt6NS
OHBGMgWs85ZDE3tJ+Sp4g4/v2OkxH+GRbsVSPUBM9qny4iR6FijvlFC5o/fjmCrj
FfBk+Du5efMOwsQ0K7AUB9pQ2jPF7hnac/qeAvB78zhoB1Rl0OE/KGlGcFKLK0El
2O/m+2cV9hLqY2FpAnzNj50MQs5I4SiEwe3GlBXwNVL4PMVMRcpRjmrMT9EHkMf4
+XWGiwUdBKDRQqXfv8sz5+O4tc16KPFo5yiPUk7vXSv90x9aTI2Pzojyq9QxPBGQ
jm/l0Kr7dw9PyGOwmAiQnEUS5juSTlDbVeu2hKslIddVm+XGFWfOnszk/UKACnXf
UwHKdyrzLqyNv7Svrne9UkQ768f8BQjgoBTojLQkZCsEto74NgB5DPihpVBMWnU6
BVCcru7NinsPyhBEm5yZbBBn9n1WVWor0IhvfaGOdxq+P0Gvt9Po/hjLvYqLwPG6
HUfV4bdfoS1RDqqs2RqDMqgzE4V4UOn/ZOEilNzL7TZNEXLf3FY1A//+mj2KQqUu
D3PsigUhkTBCKPhddzKbYi4sjtEEEzXrI0GPHWSFEOP6nFhg3l4=
=k6Md
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 25 Jan 2022 20:37
[PATCH 1/2] WIP: qsyncthingtray: Use QtWebEngine instead of QtWebKit.
e698b441069f5cfca91b86c81b2577f19cb33e60.1643139447.git.leo@famulari.name
This doesn't work. When trying to launch the web view from the tray
icon, QSyncthingTray crashes like this:

------
Could not find QtWebEngineProcess
Aborted
------

* gnu/packages/sync.scm (qsyncthingtray)[arguments]: Remove
Webkit-related argument from #:configure-flags.
[inputs]: Remove qtwebkit. Add qtdeclarative, qtwebchannel, and
qtwebengine.
---
gnu/packages/sync.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 165be17e4c..d9c91804b5 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -378,8 +378,7 @@ (define-public qsyncthingtray
"1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
;; The program is meant to be run from the git repo or source tarball.
(replace 'install
@@ -394,7 +393,7 @@ (define-public qsyncthingtray
#t))))
#:tests? #f)) ; no test target
(inputs
- (list qtbase-5 qtwebkit))
+ (list qtbase-5 qtdeclarative qtwebchannel qtwebengine))
(home-page "https://github.com/sieren/QSyncthingTray")
(synopsis "Traybar Application for Syncthing")
(description
--
2.34.0
L
L
Leo Famulari wrote on 25 Jan 2022 20:37
[PATCH 2/2] gnu: QSyncthingTray: Deprecate in favor of Debian's syncthing-gtk fork.
c56ca7faf46086cb3595f9a382b586badab18474.1643139447.git.leo@famulari.name
This package is abandoned upstream and depends on the insecure and
abandoned QtWebKit.

Upstream abandonment:


See https://issues.guix.gnu.org/53289 for more information about this change

* gnu/packages/sync.scm (qsyncthingtray): Move this variable ...
* gnu/packages/syncthing.scm (qsyncthingtray): ... to here. And make it into a
deprecated-package that points to syncthing-gtk.
---
gnu/packages/sync.scm | 51 --------------------------------------
gnu/packages/syncthing.scm | 3 +++
2 files changed, 3 insertions(+), 51 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index d9c91804b5..db0e001658 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -362,57 +362,6 @@ (define-public owncloud-client
silently and reliably flow across to every other.")
(license license:gpl2+)))
-(define-public qsyncthingtray
- (package
- (name "qsyncthingtray")
- (version "0.5.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sieren/QSyncthingTray")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; The program is meant to be run from the git repo or source tarball.
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "QSyncthingTray" bin)
- (mkdir-p (string-append out "/share/pixmaps"))
- (copy-file "../source/resources/images/Icon1024.png"
- (string-append
- out "/share/pixmaps/QSyncthingTray.png"))
- #t))))
- #:tests? #f)) ; no test target
- (inputs
- (list qtbase-5 qtdeclarative qtwebchannel qtwebengine))
- (home-page "https://github.com/sieren/QSyncthingTray")
- (synopsis "Traybar Application for Syncthing")
- (description
- "A traybar application for syncthing.
-@enumerate
-@item Shows number of connections at a glance.
-@item Traffic statistics about incoming, outgoing and total throughput.
-@item Launches Syncthing and Syncthing-iNotifier if specified.
-@item Quickly pause Syncthing with one click.
-@item Last Synced Files - Quickly see the recently synchronised files and open
-their folder.
-@item Quick Access to all shared folders.
-@item Presents Syncthing UI in a separate view instead of using the browser.
-@item Supports authenticated HTTPS connections.
-@item Uses System Notifications about current connection status.
-@item Toggle for monochrome icon.
-@end enumerate\n")
- (license license:lgpl3+)))
-
(define-public lsyncd
(package
(name "lsyncd")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c19cc97862..c96d5cc3f2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -217,6 +217,9 @@ (define-public syncthing-gtk
@end itemize\n")
(license gpl2))))
+(define-public qsyncthingtray
+ (deprecated-package "qsyncthingtray" syncthing-gtk))
+
(define-public go-github-com-jackpal-go-nat-pmp
(package
(name "go-github-com-jackpal-go-nat-pmp")
--
2.34.0
L
L
Leo Famulari wrote on 25 Jan 2022 21:14
(no subject)
(address . control@debbugs.gnu.org)
YfBaNb1nS/aGuudB@jasmine.lan
block 53289 with 53531
E
E
Efraim Flashner wrote on 26 Jan 2022 10:42
Re: [bug#53531] [PATCH 2/2] gnu: QSyncthingTray: Deprecate in favor of Debian's syncthing-gtk fork.
(name . Leo Famulari)(address . leo@famulari.name)
YfEXbRrY2Ft9PV9z@3900XT
On Tue, Jan 25, 2022 at 02:37:27PM -0500, Leo Famulari wrote:
Toggle quote (9 lines)
> This package is abandoned upstream and depends on the insecure and
> abandoned QtWebKit.
>
> Upstream abandonment:
>
> https://github.com/sieren/QSyncthingTray/issues/247
>
> See <https://issues.guix.gnu.org/53289> for more information about this change

I like this idea. Although I'm not sure about keeping the first patch.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmHxF20ACgkQQarn3Mo9
g1ECSBAAogh7ws0sATQKFHogzapYTrwtvO+JltNaT7qRgD2IR+YLMY4FurdFdOBs
AWArjhwe8oDUhRu1/Ot603vD89lAtSFzOV9bQO9xTJBxbcRQ9JNxEAQPGGOQU+QB
TDoyDryQYX/OuiA4n8MldpxdlExYt/jbQ1vC/LNerhTdk5FbpaPSjlQiLHuzvfNH
aC3qc7dX0Rcwyya65RN+6ileuiOigdgxRJgGPHUgGFhDE1IthjktBmuKFrjQ94W7
YhXAZpJs4tN9tweLr6WLJcxOq8zWPE1w+KQSaGbthvXuPvcZdS0de3WgLKrYyYUo
jd4p6wWIX8X5YBHZJbQPdWAMVuqjMgthOXr0L6gLrCWDdJuAo2NOyn0xx8N5ghqo
xRUGkDsYvF0pLZvhkPBsxysLM7O0FBLSuImc8D3BvfqgX0A+ka0sHHfIwHa2HX9w
9NGraUo4ly2drB2ALEM+MzpF9/wXLmMF7DoeQfFJo2NCt7sTBkvaVaUZ924Y7qdt
BQCROsCS/c8N9U2j7te77lvYU2PUI4RNPJFJGjxx57qbfjMJOtDId1wdNp8lcp2A
7z6bmQSSCzpkre4eic8NWWccUtQAfyLgnwAHhLU/5E5XYdnw2RBybrtiCuw3oUQ8
xsh3DwrRWcyZ1oMmNhIXUy1M1zF8pzrWFdHEI56BY1SWAYvITXc=
=KDiZ
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 26 Jan 2022 19:03
YfGND99YKtS/OJYI@jasmine.lan
On Wed, Jan 26, 2022 at 11:42:05AM +0200, Efraim Flashner wrote:
Toggle quote (2 lines)
> I like this idea. Although I'm not sure about keeping the first patch.

I forgot to mention: the first patch is just a demonstration of why
using QtWebEngine doesn't work "out of the box".
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmHxjQ8ACgkQJkb6MLrK
fwhS1Q/9HmOK0Vr9pSMgq5n6KQ92FgHdAkflbrUGaAMM22YQUnwZhGkWL5aNpFFr
sFi5FHAkXFBPdNizkkfl14+6ll6tVH1tmbrMpHFoVZiR/n+giY9PQJW0TbqxaIiR
qGrZY35KK+7yjaakPw0DZBRDVZx7z5CCtx69+j9Ike2MKxXqqunLtgnFCRjyErOd
3e3lq8dLaeOLX8Kg+J79rJV67o3IWUKVQDCfX1NQhuCVj69IN07OL5MGOYnhuWkS
U568Oq43UXnIhyoQWws9NcPNBp6nKos42SW921L1Iyktfr2gbFIIvCPsi+eEMii2
+AJbMRBVWNoUa0uV3oKCWVi4YNxbu9WD8ohuIM24JoeU2NwL++UlAdktLt569bPH
t0b74a1rF8oPE91GasvdaQsyhRkZswMSugrEKfebBcY6rX2Vq5cLt+zYuDeSPgBO
ZxPZqkL6fmp9/QUhDdu0fby9QEWWUVKpJeh7asiBmupxjzjc9OH86jqdBnrpVJ+4
ROPyqM4NAkTUy8SpyUrSaLOT9xOxy53xMCNV/pe7aKGqxsbc2p/D6PjVHI6E7LzW
cdlsRXNnOw54bOPTBbEV95gRcsEytk1bWinaHx23M4eorpF5QjiLjdYCaNdXr2+Q
rmJz/YAYkVg+B5FEIGw+9jCS9Nms4DH8r/cXwgzqaAn43rlSDxo=
=2cHv
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 9 Feb 2022 17:58
YgPysR4ar/7pYVMM@jasmine.lan
On Wed, Jan 26, 2022 at 11:42:05AM +0200, Efraim Flashner wrote:
Toggle quote (12 lines)
> On Tue, Jan 25, 2022 at 02:37:27PM -0500, Leo Famulari wrote:
> > This package is abandoned upstream and depends on the insecure and
> > abandoned QtWebKit.
> >
> > Upstream abandonment:
> >
> > https://github.com/sieren/QSyncthingTray/issues/247
> >
> > See <https://issues.guix.gnu.org/53289> for more information about this change
>
> I like this idea. Although I'm not sure about keeping the first patch.

Pushed as 4578ad78bee1dfd450962627ae66d3e15ebadad2
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmID8rEACgkQJkb6MLrK
fwi8bw//QnQZZ5uOZwA4oO3CXvWQ1ON3TzcjVTKXShGJ5NE7Ute1ZpmO+T5NW5OS
P7dCP18YzPmBxAN7DJFzPCJCfdICADHDT0uVwmE8OJZPt2V9pty/nFyDwnugQbik
yUqk/RLN6lovRSv0bPTOlCY3OBArCuOzylAOYRs99ezP8JvZZuUtXuvXm9YImG0z
fI+tc1QMiir2S03/OHdd73jDvRQnyRqHJ6/JI+MS4gGeFDa7tGJ0Zz+485AErtDB
Ta5V4uteFTD0mtgbhTG7Fw97HaaEBrcvzJJGSBOQdDrL/DNPgqccJmQ/03JnO+qJ
/wTSNLWq9iLWnivefQzcYSfDsYuY9nqz40APbFsFGXb05ntu9UUwi2EG09YnA/Nu
L3CxV9+rDoDOge64wmqhAsNAbJRehBHk5au7KIPv+jZbl7/B3IttUR+0EcQEhem0
3enwPKaLsy4bIPWZq0sXX52eIFEa/p8nCncTLIlGYfQPPkfWn6ywFSyU7dJk2ei8
3f4MiOmkp95Vj0865pynaKeBbgWzTSCANuxSyTRF/H8NSSrP0mBleiEX/xlaAUyX
PTsPGFfm+b1hZc7XZXeHFcHzOwmjISgoJbTWGil9cEQZuPlJTU9oY4HZmjZRLUr1
OLe+lNYc0iTZovjWmwAOTJsPoKa+0YD90gb+AN4BZvYIHn/yFJs=
=QfQ9
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53531@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53531
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch