[PATCH 2/7] gnu: Add plasma-shell-applet-advanced-radio-player.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 31 Oct 2023 21:18
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
29bf463ad0c5cdfb6510606699ae6af1b34522b8.1698783239.git.sughosha@disroot.org
* gnu/packages/kde-xyz.scm (plasma-shell-extension-advanced-radio-player): New variable.

Change-Id: I9c7bfd11cf4906b6096c75e0251235e6b5b5ecbb
---
gnu/packages/kde-xyz.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
index 840014de5c..7fdd107750 100644
--- a/gnu/packages/kde-xyz.scm
+++ b/gnu/packages/kde-xyz.scm
@@ -22,7 +22,8 @@ (define-module (gnu packages kde-xyz)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
- #:use-module (gnu packages gnome-xyz))
+ #:use-module (gnu packages gnome-xyz)
+ #:use-module (gnu packages qt))
(define-public flat-remix-kde-theme
(let ((commit "18ac464d5b77dd140aeb6c6b98d687c086959247")
@@ -53,3 +54,32 @@ (define-public flat-remix-kde-theme
It is mostly flat using a colorful palette with some shadows, highlights, and
gradients for some depth.")
(license license:gpl3+))))
+
+(define-public plasma-shell-applet-advanced-radio-player
+ ;; Version is not tagget, but given in package/metadata.desktop.
+ (let ((commit "894973f4d5948ce400c2a3d28def4cea3c274c47") ;version 2.4
+ (revision "0"))
+ (package
+ (name "plasma-shell-applet-advanced-radio-player")
+ (version (git-version "2.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/saurov/arp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17h79bl6akyhjh53hdp7g4a7kki8v8m2zvqs1qi0isf3nlvz0dwm"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("package" "/share/plasma/plasmoids/org.kde.plasma.advancedradio"))))
+ (propagated-inputs
+ (list qtmultimedia-5))
+ (home-page "https://invent.kde.org/saurov/arp")
+ (synopsis "Radio player extension for Plasma shell")
+ (description
+ "Advanced Radio Player is a radio player extension for Plasma shell,
+with editable list of stations.")
+ (license license:lgpl2.0+))))
--
2.41.0
S
S
Sughosha wrote on 31 Oct 2023 21:39
(address . control@debbugs.gnu.org)
06D9CCE6-7AB5-4878-A922-0DE5DD9502AA@disroot.org
merge 66856 66855 66860 66854 66859 66861 66857 66858
quit
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66860@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66860
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch