[PATCH 1/7] gnu: Add flat-remix-kde-theme.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 31 Oct 2023 21:18
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
1074f7566ecfba8ef63fee9696b472bb26d7eea0.1698783239.git.sughosha@disroot.org
* gnu/packages/kde-xyz.scm: New file.

* gnu/local.mk: Register it.

Change-Id: I5fbf36de902f553f94bdc2436cef9142302daac9
---
gnu/local.mk | 1 +
gnu/packages/kde-xyz.scm | 55 ++++++++++++++++++++++++++++++++++++++++
2 files changed, 56 insertions(+)
create mode 100644 gnu/packages/kde-xyz.scm

Toggle diff (75 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 27e57302ae..03e8c28d45 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -377,6 +377,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/kde-plasma.scm \
%D%/packages/kde-systemtools.scm \
%D%/packages/kde-utils.scm \
+ %D%/packages/kde-xyz.scm \
%D%/packages/kerberos.scm \
%D%/packages/kodi.scm \
%D%/packages/language.scm \
diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
new file mode 100644
index 0000000000..840014de5c
--- /dev/null
+++ b/gnu/packages/kde-xyz.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Sughosha <sughosha@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-xyz)
+ #:use-module (guix build-system copy)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages gnome-xyz))
+
+(define-public flat-remix-kde-theme
+ (let ((commit "18ac464d5b77dd140aeb6c6b98d687c086959247")
+ (revision "0"))
+ (package
+ (name "flat-remix-kde-theme")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/daniruiz/flat-remix-kde")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05wxcjpg3qgyc2jiidb8506s1ah7yhilb1ifk2xd61xmy7d1xmz6"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "/share"
+ #:include-regexp ("/aurorae/" "/color-schemes/" "/plasma/")))))
+ (propagated-inputs
+ (list flat-remix-gtk-theme flat-remix-icon-theme))
+ (home-page "https://drasite.com/flat-remix-kde")
+ (synopsis "KDE theme with material design")
+ (description "Flat Remix KDE is a KDE theme inspired by material design.
+It is mostly flat using a colorful palette with some shadows, highlights, and
+gradients for some depth.")
+ (license license:gpl3+))))
--
2.41.0
S
S
Sughosha wrote on 31 Oct 2023 21:39
(address . control@debbugs.gnu.org)
06D9CCE6-7AB5-4878-A922-0DE5DD9502AA@disroot.org
merge 66856 66855 66860 66854 66859 66861 66857 66858
quit
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66855@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66855
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch