(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
* gnu/packages/kde-xyz.scm: New file.
* gnu/local.mk: Register it.
Change-Id: I5fbf36de902f553f94bdc2436cef9142302daac9
---
gnu/local.mk | 1 +
gnu/packages/kde-xyz.scm | 55 ++++++++++++++++++++++++++++++++++++++++
2 files changed, 56 insertions(+)
create mode 100644 gnu/packages/kde-xyz.scm
Toggle diff (75 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 27e57302ae..03e8c28d45 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -377,6 +377,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/kde-plasma.scm \
%D%/packages/kde-systemtools.scm \
%D%/packages/kde-utils.scm \
+ %D%/packages/kde-xyz.scm \
%D%/packages/kerberos.scm \
%D%/packages/kodi.scm \
%D%/packages/language.scm \
diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
new file mode 100644
index 0000000000..840014de5c
--- /dev/null
+++ b/gnu/packages/kde-xyz.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Sughosha <sughosha@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-xyz)
+ #:use-module (guix build-system copy)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages gnome-xyz))
+
+(define-public flat-remix-kde-theme
+ (let ((commit "18ac464d5b77dd140aeb6c6b98d687c086959247")
+ (revision "0"))
+ (package
+ (name "flat-remix-kde-theme")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/daniruiz/flat-remix-kde")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05wxcjpg3qgyc2jiidb8506s1ah7yhilb1ifk2xd61xmy7d1xmz6"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "/share"
+ #:include-regexp ("/aurorae/" "/color-schemes/" "/plasma/")))))
+ (propagated-inputs
+ (list flat-remix-gtk-theme flat-remix-icon-theme))
+ (home-page "https://drasite.com/flat-remix-kde")
+ (synopsis "KDE theme with material design")
+ (description "Flat Remix KDE is a KDE theme inspired by material design.
+It is mostly flat using a colorful palette with some shadows, highlights, and
+gradients for some depth.")
+ (license license:gpl3+))))
--
2.41.0