[PATCH 7/7] gnu: Add plasma-shell-wallpaper-active-blur.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 31 Oct 2023 21:19
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
7864db3d6d178e737e763b2cf13af02b70e1caca.1698783239.git.sughosha@disroot.org
* gnu/packages/kde-xyz.scm (plasma-shell-wallpaper-active-blur): New variable.

Change-Id: I612d5885b65779100aee41879701df499b0b863b
---
gnu/packages/kde-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
index c9e8308fbf..f98a9c4af9 100644
--- a/gnu/packages/kde-xyz.scm
+++ b/gnu/packages/kde-xyz.scm
@@ -218,3 +218,28 @@ (define-public plasma-shell-applet-window-title
"This plasmoid shows the current window title and icon in Plasma panels or
Latte Dock.")
(license license:gpl2+)))
+
+(define-public plasma-shell-wallpaper-active-blur
+ (package
+ (name "plasma-shell-wallpaper-active-blur")
+ (version "2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bouteillerAlan/blurredwallpaper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b688d4p8n1wkhw3bp1zhxi5xbx806fy5hcgc8jrjj2kaclk408n"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "/share/plasma/wallpapers/a2n.blur"
+ #:include-regexp ("/assets/" "/contents/" "metadata.json")))))
+ (home-page "https://github.com/bouteillerAlan/blurredwallpaper")
+ (synopsis "Blurred wallpaper plugin for Plasma shell")
+ (description
+ "This Plasma wallpaper plugin blurs the wallpaper when a window is
+active.")
+ (license license:gpl2+)))
--
2.41.0
S
S
Sughosha wrote on 31 Oct 2023 21:39
(address . control@debbugs.gnu.org)
06D9CCE6-7AB5-4878-A922-0DE5DD9502AA@disroot.org
merge 66856 66855 66860 66854 66859 66861 66857 66858
quit
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66858@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66858
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch