[PATCH 4/7] gnu: Add plasma-shell-applet-window-appmenu.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 31 Oct 2023 21:18
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
685e6bae23ac86545ad5be6292d0c12eb6eba0bf.1698783239.git.sughosha@disroot.org
* gnu/packages/kde-xyz.scm (plasma-shell-applet-window-appmenu): New variable.

Change-Id: I44db8f08a841669ae750aaf0a58c931d46fe0a99
---
gnu/packages/kde-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 44 insertions(+), 1 deletion(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
index 5aeae290c8..cde12d45b4 100644
--- a/gnu/packages/kde-xyz.scm
+++ b/gnu/packages/kde-xyz.scm
@@ -18,12 +18,16 @@
(define-module (gnu packages kde-xyz)
#:use-module (guix build-system copy)
+ #:use-module (guix build-system qt)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages gnome-xyz)
- #:use-module (gnu packages qt))
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-plasma)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages xorg))
(define-public flat-remix-kde-theme
(let ((commit "18ac464d5b77dd140aeb6c6b98d687c086959247")
@@ -109,3 +113,42 @@ (define-public plasma-shell-applet-better-inline-clock
(description
"This package provides single line clock applet for Plasma shell.")
(license license:gpl2+))))
+
+(define-public plasma-shell-applet-window-appmenu
+ ;; This commit fixes appmenu being unresponsive when hovering over other
+ ;; options after clicking on one.
+ (let ((commit "e044296256c866177c5c929f9280fb86b26dbf06")
+ (revision "0"))
+ (package
+ (name "plasma-shell-applet-window-appmenu")
+ (version (git-version "0.8.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/psifidotos/applet-window-appmenu")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n8jgn6vaw4ncvrqm1snn6izg16by1f9rzkjypphr8a6z65nz2dn"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules))
+ (inputs
+ (list libsm
+ kconfigwidgets
+ kdecoration
+ kirigami
+ kitemmodels
+ kwayland
+ kwindowsystem
+ plasma-framework
+ plasma-workspace
+ qtdeclarative-5
+ qtx11extras))
+ (home-page "https://github.com/psifidotos/applet-window-appmenu")
+ (synopsis "Appmenu applet for Plasma shell")
+ (description
+ "This plasmoid shows the current window appmenu in Plasma panels or
+Latte Dock.")
+ (license license:gpl2+))))
--
2.41.0
S
S
Sughosha wrote on 31 Oct 2023 21:39
(address . control@debbugs.gnu.org)
06D9CCE6-7AB5-4878-A922-0DE5DD9502AA@disroot.org
merge 66856 66855 66860 66854 66859 66861 66857 66858
quit
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66859@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66859
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch