[PATCH 6/7] gnu: Add plasma-shell-applet-window-title.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 31 Oct 2023 21:19
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
e936a8d03a273973c35f7d3684acf61fa33c81a4.1698783239.git.sughosha@disroot.org
* gnu/packages/kde-xyz.scm (plasma-shell-applet-window-title): New variable.

Change-Id: I1e08861c4c44d8b6e621a30c8cb562f9129f6f08
---
gnu/packages/kde-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
index 42d5046cf2..c9e8308fbf 100644
--- a/gnu/packages/kde-xyz.scm
+++ b/gnu/packages/kde-xyz.scm
@@ -189,3 +189,32 @@ (define-public plasma-shell-applet-window-buttons
(description
"This plasmoid shows window buttons in Plasma panels or Latte Dock.")
(license license:gpl2+)))
+
+(define-public plasma-shell-applet-window-title
+ (package
+ (name "plasma-shell-applet-window-title")
+ (version "0.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/psifidotos/applet-window-title")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01n663sy638v80gfclhy50xr22wlhg00yhgzwnsiqjvk42if49ib"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "/share/plasma/plasmoids/org.kde.windowtitle"
+ #:include-regexp ("/contents/" "metadata.desktop")))))
+ (inputs
+ (list kdeclarative
+ kirigami
+ plasma-workspace))
+ (home-page "https://github.com/psifidotos/applet-window-title")
+ (synopsis "Application title and icon for active window for Plasma shell")
+ (description
+ "This plasmoid shows the current window title and icon in Plasma panels or
+Latte Dock.")
+ (license license:gpl2+)))
--
2.41.0
S
S
Sughosha wrote on 31 Oct 2023 21:39
(address . control@debbugs.gnu.org)
06D9CCE6-7AB5-4878-A922-0DE5DD9502AA@disroot.org
merge 66856 66855 66860 66854 66859 66861 66857 66858
quit
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66857@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66857
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch