[PATCH v2 11/23] DRAFT import: juliahub: Improve dependency management.

  • Done
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
Merged with

Debbugs page

Simon Tournier wrote 1 years ago
(address . 62202@debbugs.gnu.org)
9c97220836376a2e6de87f52b4a7b842581225ed.1695060058.git.zimon.toutoune@gmail.com
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>

Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
---
guix/import/juliahub.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)

Toggle diff (60 lines)
diff --git a/guix/import/juliahub.scm b/guix/import/juliahub.scm
index b1eeb736a824..fc25ba1d4220 100644
--- a/guix/import/juliahub.scm
+++ b/guix/import/juliahub.scm
@@ -168,22 +168,20 @@ (define* (juliahub-fetch name #:key (version #f))
json->juliahub-package))
(define (make-julia-sexp name source home-page synopsis description
- dependencies test-dependencies-names licenses)
+ direct-dependencies test-dependencies-names licenses)
"Return the `package' s-expression for a Julia package with the given NAME,
-VERSION, URI, HASH, HOME-PAGE, DESCRIPTION, DEPENDENCIES,
+VERSION, URI, HASH, HOME-PAGE, DESCRIPTION, DIRECT-DEPENDENCIES,
TEST-DEPENDENCIES-NAMES and LICENSES."
`(package
(name ,(julia-name->guix-name name))
(version ,version)
(source ,source)
(build-system julia-build-system)
- ,@(let ((direct-dependencies
- (filter julia-dependency-direct? dependencies)))
- (if (null? direct-dependencies)
- '()
- `((propagated-inputs
- (list ,@(map (compose julia-name->guix-name juliahub-dependency-name)
- direct-dependencies))))))
+ ,@(if (null? direct-dependencies)
+ '()
+ `((propagated-inputs
+ (list ,@(map (compose julia-name->guix-name juliahub-dependency-name)
+ direct-dependencies)))))
,@(if (null? test-dependencies-names)
'()
`((native-inputs
@@ -211,9 +209,12 @@ (define* (juliahub->guix-package package-name
`(tag-or-commit
. ,(string-append
"v" (juliahub-package-version package))))))
- (let* ((dependencies-names
+ (let* ((direct-dependencies
+ (filter juliahub-dependency-direct?
+ (juliahub-package-dependencies package)))
+ (dependencies-names
(map juliahub-dependency-name
- (juliahub-package-direct-dependencies package)))
+ direct-dependencies))
(licenses
(map spdx-string->license
(list (juliahub-package-license package))))
@@ -224,7 +225,7 @@ (define* (juliahub->guix-package package-name
(juliahub-package-homepage package)
(juliahub-package-description package)
(beautify-description (juliahub-package-readme package))
- (juliahub-package-direct-dependencies package)
+ direct-dependencies
test-dependencies-names
licenses)
(append dependencies-names test-dependencies-names))))
--
2.38.1
Simon Tournier wrote 1 years ago
control message for bug #66092
(address . control@debbugs.gnu.org)
86a5tjnqt7.fsf@gmail.com
close 66092
quit
Simon Tournier wrote 1 years ago
control message for bug #66075
(address . control@debbugs.gnu.org)
868r93mc3w.fsf@gmail.com
merge 66075 66092 66091 66090
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66092@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66092
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help