[PATCH v2 22/23] DRAFT import: juliahub: output package names as symbols.

  • Done
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
Merged with

Debbugs page

Simon Tournier wrote 1 years ago
(address . 62202@debbugs.gnu.org)
11807ccb1ff39f04a76a62e37556c9c5727b36a2.1695060058.git.zimon.toutoune@gmail.com
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>

Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
---
guix/import/juliahub.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/guix/import/juliahub.scm b/guix/import/juliahub.scm
index 06574db724fe..be874b193b28 100644
--- a/guix/import/juliahub.scm
+++ b/guix/import/juliahub.scm
@@ -261,12 +261,15 @@ (define (make-julia-sexp name version source home-page synopsis description
'()
`((propagated-inputs
(list
- ,@(map (compose julia-name->guix-name juliahub-dependency-name)
+ ,@(map (compose string->symbol
+ julia-name->guix-name
+ juliahub-dependency-name)
direct-dependencies)))))
,@(if (null? test-dependencies-names)
'()
`((native-inputs
- (list ,@(map julia-name->guix-name test-dependencies-names)))))
+ (list ,@(map (compose string->symbol julia-name->guix-name)
+ test-dependencies-names)))))
(synopsis ,synopsis)
(description ,description)
(home-page ,home-page)
--
2.38.1
Simon Tournier wrote 1 years ago
control message for bug #66091
(address . control@debbugs.gnu.org)
868r93nqt4.fsf@gmail.com
close 66091
quit
Simon Tournier wrote 1 years ago
control message for bug #66075
(address . control@debbugs.gnu.org)
868r93mc3w.fsf@gmail.com
merge 66075 66092 66091 66090
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66091@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66091
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help