[PATCH v2 19/23] DRAFT import: juliahub: Fix license management.

  • Done
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
Merged with

Debbugs page

Simon Tournier wrote 1 years ago
(address . 62202@debbugs.gnu.org)
80498439f6fb5e349b5e9fc643e6538a361983fd.1695060058.git.zimon.toutoune@gmail.com
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>

Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
---
guix/import/juliahub.scm | 15 +++++----------
1 file changed, 5 insertions(+), 10 deletions(-)

Toggle diff (51 lines)
diff --git a/guix/import/juliahub.scm b/guix/import/juliahub.scm
index 338f0424414c..e4b26bea340a 100644
--- a/guix/import/juliahub.scm
+++ b/guix/import/juliahub.scm
@@ -248,10 +248,10 @@ (define* (juliahub-fetch name #:key (version #f))
(and=> (json-fetch url) json->juliahub-package)))
(define (make-julia-sexp name source home-page synopsis description
- direct-dependencies test-dependencies-names licenses)
+ direct-dependencies test-dependencies-names license)
"Return the `package' s-expression for a Julia package with the given NAME,
VERSION, URI, HASH, HOME-PAGE, DESCRIPTION, DIRECT-DEPENDENCIES,
-TEST-DEPENDENCIES-NAMES and LICENSES."
+TEST-DEPENDENCIES-NAMES and LICENSE."
`(package
(name ,(julia-name->guix-name name))
(version ,version)
@@ -270,10 +270,8 @@ (define (make-julia-sexp name source home-page synopsis description
(synopsis ,synopsis)
(description ,description)
(home-page ,home-page)
- (license ,(match licenses
- (() #f)
- ((license) (license->symbol license))
- (_ `(list ,@(map license->symbol licenses)))))))
+ (license
+ ,(if license (spdx-string->license license) #f))))
(define* (juliahub->guix-package package-name
#:key version #:allow-other-keys)
@@ -301,9 +299,6 @@ (define* (juliahub->guix-package package-name
(dependencies-names
(map juliahub-dependency-name
direct-dependencies))
- (licenses
- (map spdx-string->license
- (list (juliahub-package-license package))))
(test-dependencies-names
(if subdir
(parse-test-dependencies
@@ -319,7 +314,7 @@ (define* (juliahub->guix-package package-name
(juliahub-package-readme package))
direct-dependencies
test-dependencies-names
- licenses)
+ (juliahub-package-license package))
(append dependencies-names test-dependencies-names))))
(values #f '()))))
--
2.38.1
Simon Tournier wrote 1 years ago
control message for bug #66080
(address . control@debbugs.gnu.org)
86r0mvmc85.fsf@gmail.com
close 66080
quit
Simon Tournier wrote 1 years ago
control message for bug #66075
(address . control@debbugs.gnu.org)
86cyyfmc6f.fsf@gmail.com
merge 66075 66080
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86bkdzmc63.fsf@gmail.com
merge 66075 66081
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86a5tjmc4o.fsf@gmail.com
merge 66075 66089 66088 66087 66086 66085 66084 66083 66082
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
868r93mc3w.fsf@gmail.com
merge 66075 66092 66091 66090
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66080@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66080
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help