[PATCH v2 07/23] DRAFT import: juliahub: Add indirect dependencies.

  • Done
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
Merged with

Debbugs page

Simon Tournier wrote 1 years ago
(address . 62202@debbugs.gnu.org)
9582ebba5df585ec5c71e008e71aaefafc036753.1695060058.git.zimon.toutoune@gmail.com
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>

Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
---
guix/import/juliahub.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/guix/import/juliahub.scm b/guix/import/juliahub.scm
index 4c3ceed10904..fb361a004435 100644
--- a/guix/import/juliahub.scm
+++ b/guix/import/juliahub.scm
@@ -67,6 +67,16 @@ (define (json->juliahub-direct-dependencies vector)
#f)))
(vector->list vector))))
+(define (json->juliahub-indirect-dependencies vector)
+ (if (vector? vector)
+ (filter-map
+ (lambda (el)
+ (let ((dep (json->juliahub-dependency el)))
+ (if (not (juliahub-dependency-direct? dep))
+ dep
+ #f)))
+ (vector->list vector))))
+
(define (ini-list->extra-dependencies lst)
(match lst
(('(extras) ooo ...)
@@ -103,6 +113,9 @@ (define-json-mapping <juliahub-package> make-juliahub-package juliahub-package?
(direct-dependencies
juliahub-package-direct-dependencies "deps"
json->juliahub-direct-dependencies) ;list of <juliahub-dependency>
+ (indirect-dependencies
+ juliahub-package-indirect-dependencies "deps"
+ json->juliahub-indirect-dependencies) ;list of <juliahub-dependency>
(url juliahub-package-url) ;string
(uuid juliahub-package-uuid) ;string
(license juliahub-package-license)) ;string
@@ -181,7 +194,7 @@ (define* (juliahub->guix-package package-name
(juliahub-package-direct-dependencies package)
test-dependencies-names
licenses)
- (append dependencies-names test-dependencies))))
+ (append dependencies-names test-dependencies-names))))
(values #f '()))))
(define* (import-release package #:key (version #f))
--
2.38.1
Simon Tournier wrote 1 years ago
control message for bug #66075
(address . control@debbugs.gnu.org)
86jzsnmc7z.fsf@gmail.com
close 66075
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86il87mc7j.fsf@gmail.com
merge 66075 66076
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86h6nrmc72.fsf@gmail.com
merge 66075 66077
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86fs3bmc6t.fsf@gmail.com
merge 66075 66078
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86edivmc6m.fsf@gmail.com
merge 66075 66079
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86cyyfmc6f.fsf@gmail.com
merge 66075 66080
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86bkdzmc63.fsf@gmail.com
merge 66075 66081
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
86a5tjmc4o.fsf@gmail.com
merge 66075 66089 66088 66087 66086 66085 66084 66083 66082
quit
Simon Tournier wrote 1 years ago
(address . control@debbugs.gnu.org)
868r93mc3w.fsf@gmail.com
merge 66075 66092 66091 66090
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66075@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66075
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help