Simon Tournier wrote 1 years ago
(address . 62202@debbugs.gnu.org)
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>
Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
---
guix/import/juliahub.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
Toggle diff (35 lines)
diff --git a/guix/import/juliahub.scm b/guix/import/juliahub.scm
index 2ea461b72aba..b646f9329562 100644
--- a/guix/import/juliahub.scm
+++ b/guix/import/juliahub.scm
@@ -233,14 +233,12 @@ (define (make-julia-sexp name source home-page synopsis description
((license) (license->symbol license))
(_ `(list ,@(map license->symbol licenses)))))))
-;; TODO handle subdir case properly.
-
(define* (juliahub->guix-package package-name
#:key version #:allow-other-keys)
"Fetch the metadata for PACKAGE-NAME from juliahub.org, and return the
`package' s-expression corresponding to that package, or #f on failure.
Optionally include a VERSION string to fetch a specific version juliahub."
- (let* ((package-toml (ini-fetch (general-url name "Package.toml")))
+ (let* ((package-toml (ini-fetch (general-url package-name "Package.toml")))
(subdir (assoc-ref package-toml 'subdir))
(tag (latest-git-tag (assoc-ref package-toml 'repo)))
(package (if version
@@ -264,7 +262,11 @@ (define* (juliahub->guix-package package-name
(licenses
(map spdx-string->license
(list (juliahub-package-license package))))
- (test-dependencies-names (parse-test-dependencies directory)))
+ (test-dependencies-names
+ (if subdir
+ (parse-test-dependencies
+ (string-append subdir "/" directory))
+ (parse-test-dependencies directory))))
(values (make-julia-sexp
package-name
source
--
2.38.1