Simon Tournier wrote 1 years ago
(address . 62202@debbugs.gnu.org)
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>
Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
---
guix/import/juliahub.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (27 lines)
diff --git a/guix/import/juliahub.scm b/guix/import/juliahub.scm
index e4b26bea340a..94d4ae823334 100644
--- a/guix/import/juliahub.scm
+++ b/guix/import/juliahub.scm
@@ -247,10 +247,10 @@ (define* (juliahub-fetch name #:key (version #f))
(string-append (juliahub-url name) "pkg.json"))))
(and=> (json-fetch url) json->juliahub-package)))
-(define (make-julia-sexp name source home-page synopsis description
+(define (make-julia-sexp name version source home-page synopsis description
direct-dependencies test-dependencies-names license)
"Return the `package' s-expression for a Julia package with the given NAME,
-VERSION, URI, HASH, HOME-PAGE, DESCRIPTION, DIRECT-DEPENDENCIES,
+VERSION, SOURCE, HOME-PAGE, DESCRIPTION, DIRECT-DEPENDENCIES,
TEST-DEPENDENCIES-NAMES and LICENSE."
`(package
(name ,(julia-name->guix-name name))
@@ -306,6 +306,7 @@ (define* (juliahub->guix-package package-name
(parse-test-dependencies directory))))
(values (make-julia-sexp
package-name
+ (juliahub-package-version package)
source
(juliahub-package-homepage package)
(juliahub-package-description package)
--
2.38.1