[PATCH 12/39] gnu: Add ocaml-mirage-unix.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
Merged with
C
C
Csepp wrote on 9 Jan 2023 01:35
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20230109003529.23375-12-raingloom@riseup.net
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-mirage-unix): New variable.
---
gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 447b537637..83413fa541 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3809,6 +3809,26 @@ (define-public ocaml-duration
provided check the input and raise on negative or out of bound input.")
(license license:isc)))
+(define-public ocaml-mirage-unix
+ (package
+ (name "ocaml-mirage-unix")
+ (version "5.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ "https://github.com/mirage/mirage-unix/releases/download/v5.0.1/mirage-unix-5.0.1.tbz")
+ (sha256
+ (base32
+ "1y44hvsd5lxqbazwkv9n6cn936lpn8l7v82wf55w4183fp70nnjk"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-lwt ocaml-duration ocaml-mirage-runtime))
+ (home-page "https://github.com/mirage/mirage-unix")
+ (synopsis "Unix core platform libraries for MirageOS")
+ (description
+ "This package provides the MirageOS `OS` library for Unix targets, which
+handles the main loop and timers.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1
C
C
Csepp wrote on 9 Jan 2023 14:51
merging accidental multiple submission
(address . control@debbugs.gnu.org)
86eds3hjvn.fsf@riseup.net
merge 60671 60672 60673 60674 60675 60676 60677 60678 60679 60680 60681 60682 60683
thanks

Sorry, and thanks nckx for helping me sort this out!
C
C
Christopher Baines wrote on 7 Feb 2023 08:54
tag 60674 moreinfo
(address . control@debbugs.gnu.org)
87cz6lykon.fsf@cbaines.net
tags 60674 + moreinfo
quit
?