[PATCH 11/39] gnu: Add ocaml-duration.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
Merged with
C
C
Csepp wrote on 9 Jan 2023 01:35
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20230109003529.23375-11-raingloom@riseup.net
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-duration): New variable.
---
gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d33b5ba5f0..447b537637 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3785,6 +3785,30 @@ (define-public ocaml-mirage
a fully-standalone, specialised unikernel.")
(license license:isc)))
+(define-public ocaml-duration
+ (package
+ (name "ocaml-duration")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/hannesm/duration/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vvxi0ipxmdz1k4h501brvccniwf3wpc32djbccyyrzraiz7qkff"))))
+ (build-system dune-build-system)
+ (native-inputs (list ocaml-alcotest))
+ (home-page "https://github.com/hannesm/duration")
+ (synopsis "Conversions to various time units")
+ (description
+ "This package provides a duration is represented in nanoseconds as an
+unsigned 64 bit integer. This has a range of up to 584 years. Functions
+provided check the input and raise on negative or out of bound input.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1
C
C
Csepp wrote on 9 Jan 2023 14:51
merging accidental multiple submission
(address . control@debbugs.gnu.org)
86eds3hjvn.fsf@riseup.net
merge 60671 60672 60673 60674 60675 60676 60677 60678 60679 60680 60681 60682 60683
thanks

Sorry, and thanks nckx for helping me sort this out!
C
C
Christopher Baines wrote on 7 Feb 2023 08:54
tag 60674 moreinfo
(address . control@debbugs.gnu.org)
87cz6lykon.fsf@cbaines.net
tags 60674 + moreinfo
quit
?