[PATCH 03/39] gnu: Add ocaml-ipaddr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
Merged with
C
C
Csepp wrote on 9 Jan 2023 01:34
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20230109003529.23375-3-raingloom@riseup.net
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-ipaddr): New variable.
---
gnu/packages/ocaml.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5adbeda74a..7f36df6111 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3588,6 +3588,19 @@ (define-public ocaml-macaddr
@end itemize")
(license license:isc)))
+(define-public ocaml-ipaddr
+ ;; same repo and versions as ocaml-macaddr
+ (package
+ (inherit ocaml-macaddr)
+ (name "ocaml-ipaddr")
+ (arguments '(#:package "ipaddr"))
+ (propagated-inputs (list ocaml-macaddr ocaml-domain-name))
+ (synopsis
+ "Library for manipulation of IP (and MAC) address representations")
+ (description
+ "IP address types with serialization, supporting a wide range of RFCs.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1
C
C
Csepp wrote on 9 Jan 2023 14:51
merging accidental multiple submission
(address . control@debbugs.gnu.org)
86eds3hjvn.fsf@riseup.net
merge 60671 60672 60673 60674 60675 60676 60677 60678 60679 60680 60681 60682 60683
thanks

Sorry, and thanks nckx for helping me sort this out!
C
C
Christopher Baines wrote on 7 Feb 2023 08:54
tag 60674 moreinfo
(address . control@debbugs.gnu.org)
87cz6lykon.fsf@cbaines.net
tags 60674 + moreinfo
quit
?