[PATCH 10/39] gnu: Add ocaml-mirage.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
Merged with
C
C
Csepp wrote on 9 Jan 2023 01:35
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20230109003529.23375-10-raingloom@riseup.net
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-mirage): New variable.
---
gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 945ed87701..d33b5ba5f0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3761,6 +3761,30 @@ (define-public ocaml-functoria
case is mirage.")
(license license:isc)))
+(define-public ocaml-mirage
+ (package
+ (inherit ocaml-functoria-runtime)
+ (name "ocaml-mirage")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "mirage"
+ ;; TODO again, wants opam, other tests seem to pass
+ ;; look for a way to disable tests that want network access
+ #:tests? #f))
+ (propagated-inputs
+ (list ocaml-astring ocaml-bos ocaml-functoria ocaml-ipaddr ocaml-logs
+ ocaml-mirage-runtime ocaml-opam-monorepo))
+ (native-inputs (list ocaml-alcotest ocaml-fmt))
+ (home-page "https://github.com/mirage/mirage")
+ (synopsis
+ "The MirageOS library operating system")
+ (description
+ "Library operating system that constructs unikernels for secure,
+high-performance network applications across a variety of cloud computing and
+mobile platforms. Code can be developed on a normal OS and then compiled into
+a fully-standalone, specialised unikernel.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1
C
C
Csepp wrote on 9 Jan 2023 14:51
merging accidental multiple submission
(address . control@debbugs.gnu.org)
86eds3hjvn.fsf@riseup.net
merge 60671 60672 60673 60674 60675 60676 60677 60678 60679 60680 60681 60682 60683
thanks

Sorry, and thanks nckx for helping me sort this out!
C
C
Christopher Baines wrote on 7 Feb 2023 08:54
tag 60674 moreinfo
(address . control@debbugs.gnu.org)
87cz6lykon.fsf@cbaines.net
tags 60674 + moreinfo
quit
?