[PATCH 09/39] gnu: Add ocaml-functoria.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
Merged with
C
C
Csepp wrote on 9 Jan 2023 01:34
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20230109003529.23375-9-raingloom@riseup.net
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-functoria): New variable.
---
gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e0e6a7e1cb..945ed87701 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3738,6 +3738,29 @@ (define-public ocaml-mirage-runtime
applications built with MirageOS")
(license license:isc)))
+(define-public ocaml-functoria
+ (package
+ (inherit ocaml-functoria-runtime)
+ (name "ocaml-functoria")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "functoria"
+ ;; TODO again, wants opam, other tests seem to pass
+ ;; look for a way to disable tests that want network access
+ #:tests? #f))
+ (propagated-inputs (list ocaml-cmdliner ocaml-rresult ocaml-result
+ ocaml-astring ocaml-fmt ocaml-logs ocaml-bos
+ ocaml-fpath ocaml-emile ocaml-uri))
+ (native-inputs (list ocaml-alcotest ocaml-functoria-runtime))
+ (home-page "https://github.com/mirage/mirage")
+ (synopsis
+ "DSL to organize functor applications")
+ (description
+ "DSL to describe a set of modules and functors, their types and
+how to apply them in order to produce a complete application. The main use
+case is mirage.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1
C
C
Csepp wrote on 9 Jan 2023 14:51
merging accidental multiple submission
(address . control@debbugs.gnu.org)
86eds3hjvn.fsf@riseup.net
merge 60671 60672 60673 60674 60675 60676 60677 60678 60679 60680 60681 60682 60683
thanks

Sorry, and thanks nckx for helping me sort this out!
C
C
Christopher Baines wrote on 7 Feb 2023 08:54
tag 60674 moreinfo
(address . control@debbugs.gnu.org)
87cz6lykon.fsf@cbaines.net
tags 60674 + moreinfo
quit
?