[PATCH 07/39] gnu: Add ocaml-functoria-runtime

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
Merged with
C
C
Csepp wrote on 9 Jan 2023 01:34
(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
20230109003529.23375-7-raingloom@riseup.net
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (mirage-version, mirage-origin,
ocaml-functoria-runtime): New variables.
---
gnu/packages/ocaml.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 034924d9ff..1cc930292c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3682,6 +3682,41 @@ (define-public ocaml-emile
according RFC2047.")
(license license:expat)))
+(define-public ocaml-functoria-runtime
+ (package
+ (name "ocaml-functoria-runtime")
+ (version "4.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mirage/mirage/")
+ (commit (string-append "v" version))))
+ ;; TODO this origin is used by multiple packages, so what should the name
+ ;; field say?
+ (file-name (git-file-name "mirage" version))
+ (sha256
+ (base32
+ "151adbcn4zmhxgh4g10flamlgwd90pppjvk0lhy2p3yxyn55f914"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "functoria-runtime"
+ ;; TODO
+ ;; again, requires opam for tests, which needs network access.
+ ;; most other tests seem to pass.
+ #:tests? #f))
+ (propagated-inputs
+ (list ocaml-cmdliner ocaml-fmt ocaml-logs ocaml-bos ocaml-ipaddr
+ ocaml-emile ocaml-uri))
+ (native-inputs
+ (list ocaml-alcotest))
+ (home-page "https://github.com/mirage/mirage")
+ (synopsis "Runtime support library for functoria-generated code")
+ (description
+ "This is the runtime support library for code generated by functoria.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1
C
C
Csepp wrote on 9 Jan 2023 14:51
merging accidental multiple submission
(address . control@debbugs.gnu.org)
86eds3hjvn.fsf@riseup.net
merge 60671 60672 60673 60674 60675 60676 60677 60678 60679 60680 60681 60682 60683
thanks

Sorry, and thanks nckx for helping me sort this out!
C
C
Christopher Baines wrote on 7 Feb 2023 08:54
tag 60674 moreinfo
(address . control@debbugs.gnu.org)
87cz6lykon.fsf@cbaines.net
tags 60674 + moreinfo
quit
?