[gnu: Add dua-cli. 13/27] gnu: Add rust-object-0.28.

  • Open
  • quality assurance status badge
Details
3 participants
  • antlers
  • Aleksandr Vityazev
  • Maxime Devos
Owner
unassigned
Submitted by
antlers
Severity
normal
Merged with
A
A
antlers wrote on 18 Jun 2022 21:56
20220618195656.10108-14-antlers@luris.net
* gnu/packages/crates-io.scm (rust-object-0.28): New variable.
(rust-object-0.24): Inherit from rust-object-0.27.
(rust-object-0.17): Inherit from rust-object-0.22.
(rust-object-0.12): Inherit from rust-object-0.17.
---
:100644 100644 bdf4f67fb7 d3dab258f1 M gnu/packages/crates-io.scm
gnu/packages/crates-io.scm | 48 ++++++++++++++++++++++++++++----------
1 file changed, 36 insertions(+), 12 deletions(-)

Toggle diff (106 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bdf4f67fb7..d3dab258f1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39045,7 +39045,7 @@ (define-public rust-objc-test-utils-0.0
(define-public rust-object-0.28
(package
(name "rust-object")
- (version "0.28.2")
+ (version "0.28.4")
(source
(origin
(method url-fetch)
@@ -39054,7 +39054,7 @@ (define-public rust-object-0.28
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1wgv6gx69rpn4jjqs24kvafwsic1q06iaafs5mb9hy34hp7c3x89"))))
+ "0964501nlfh806mik3f9v6n05mx74qa0w7byvn0sqpwm5lprhb74"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
@@ -39088,10 +39088,40 @@ (define-public rust-object-0.28
file formats.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-object-0.24
+(define-public rust-object-0.27
(package
(inherit rust-object-0.28)
(name "rust-object")
+ (version "0.27.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "object" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ygv9zgi9wz6q5f2z9xn72i0c97jjr1dgj30kbyicdhxk8zivb37"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ ("rust-crc32fast" ,rust-crc32fast-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+ ("rust-wasmparser" ,rust-wasmparser-0.57))))
+ (home-page "https://github.com/gimli-rs/object")
+ (synopsis "Parse object file formats")
+ (description
+ "This package provides a unified interface for parsing object file
+formats.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-object-0.24
+ (package
+ (inherit rust-object-0.27)
+ (name "rust-object")
(version "0.24.0")
(source
(origin
@@ -39167,7 +39197,7 @@ (define-public rust-object-0.22
(define-public rust-object-0.17
(package
- (inherit rust-object-0.23)
+ (inherit rust-object-0.22)
(name "rust-object")
(version "0.17.0")
(source
@@ -39193,6 +39223,7 @@ (define-public rust-object-0.17
(define-public rust-object-0.12
(package
+ (inherit rust-object-0.17)
(name "rust-object")
(version "0.12.0")
(source
@@ -39204,7 +39235,6 @@ (define-public rust-object-0.12
(sha256
(base32
"1dch1ajjp05d16lig1dnvisfis0hrlrvw9lcwy1hwgdcym3z6jnz"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -39214,13 +39244,7 @@ (define-public rust-object-0.12
("rust-scroll" ,rust-scroll-0.9)
("rust-uuid" ,rust-uuid-0.7))
#:cargo-development-inputs
- (("rust-memmap" ,rust-memmap-0.7))))
- (home-page "https://github.com/gimli-rs/object")
- (synopsis "Parse object file formats")
- (description
- "This package provides a unified interface for parsing object file
-formats.")
- (license (list license:expat license:asl2.0))))
+ (("rust-memmap" ,rust-memmap-0.7))))))
(define-public rust-odds-0.3
(package
--
2.36.0
M
M
Maxime Devos wrote on 19 Jun 2022 11:04
Re: [bug#56057] [PATCH 00/27] gnu: Add dua-cli.
(address . control@debbugs.gnu.org)
79b17d35358df25550bf846d732a57044c8436dd.camel@telenet.be
merge 56057 56056 56061 56059 56062 56058 56060 56063 56064 56065 56066 56069 56067 56074 56068 56073 56072 56070 56071 56057
thanks
A
A
Aleksandr Vityazev wrote on 24 Jul 2022 23:59
Re: [bug#56057] [gnu: Add dua-cli. 20/27] gnu: Add rust-textwrap-0.15.
(name . antlers)(address . autumnalantlers@gmail.com)
87lesikw8s.fsf@posteo.org
Hi,

The textwrap-0.15 build will fail

On 2022-06-18, 12:56 -0700, antlers <autumnalantlers@gmail.com> wrote:

Toggle quote (74 lines)
> * gnu/packages/crates-io.scm (rust-textwrap-0.15): New variable.
> (rust-textwrap-0.12): Inherit from rust-textwrap-0.15.
> ---
> :100644 100644 fd431e544b f9aabbb334 M gnu/packages/crates-io.scm
> gnu/packages/crates-io.scm | 32 +++++++++++++++++++++++++++-----
> 1 file changed, 27 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index fd431e544b..f9aabbb334 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -62665,10 +62665,10 @@ (define-public rust-text-size-1
> (description "This package provides a newtypes for text offsets")
> (license (list license:expat license:asl2.0))))
>
> -(define-public rust-textwrap-0.12
> +(define-public rust-textwrap-0.15
> (package
> (name "rust-textwrap")
> - (version "0.12.1")
> + (version "0.15.0")
> (source
> (origin
> (method url-fetch)
> @@ -62677,16 +62677,17 @@ (define-public rust-textwrap-0.12
> (string-append name "-" version ".tar.gz"))
> (sha256
> (base32
> - "12978qmkl5gcp94lxndpvp9qxq8mxp7hm9xbrw3422dgikchhc10"))))
> + "1yw513k61lfiwgqrfvsjw1a5wpvm0azhpjr2kr0jhnq9c56is55i"))))
> (build-system cargo-build-system)
> (arguments
> `(#:skip-build? #t
> #:cargo-inputs
> (("rust-hyphenation" ,rust-hyphenation-0.8)
> + ("rust-smawk" ,rust-smawk-0.3)
> ("rust-terminal-size" ,rust-terminal-size-0.1)
> + ("rust-unicode-linebreak" ,rust-unicode-linebreak-0.1)
> ("rust-unicode-width" ,rust-unicode-width-0.1))))
> - (home-page
> - "https://github.com/mgeisler/textwrap")
> + (home-page "https://github.com/mgeisler/textwrap")
> (synopsis "Library for word wrapping, indenting, and dedenting strings")
> (description
> "Textwrap is a small library for word wrapping, indenting, and dedenting
> @@ -62695,6 +62696,27 @@ (define-public rust-textwrap-0.12
> handle Unicode characters correctly.")
> (license license:expat)))
>
> +(define-public rust-textwrap-0.12
> + (package
> + (inherit rust-textwrap-0.15)
> + (name "rust-textwrap")
> + (version "0.12.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (crate-uri "textwrap" version))
> + (file-name
> + (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "12978qmkl5gcp94lxndpvp9qxq8mxp7hm9xbrw3422dgikchhc10"))))
> + (arguments
> + `(#:skip-build? #t
> + #:cargo-inputs
> + (("rust-hyphenation" ,rust-hyphenation-0.8)
> + ("rust-terminal-size" ,rust-terminal-size-0.1)
> + ("rust-unicode-width" ,rust-unicode-width-0.1))))))
> +
> (define-public rust-textwrap-0.11
> (package
> (inherit rust-textwrap-0.12)

To correctly build textwrap-0.15 u can use these patches (see in
attachments). Although, of course, it does not play a big role, older
versions also fails when building.

--

Aleksandr Vityazev
From a44052bca7754bd86401aaf207bb85031ff43707 Mon Sep 17 00:00:00 2001
Message-Id: <a44052bca7754bd86401aaf207bb85031ff43707.1658698211.git.avityazev@posteo.org>
In-Reply-To: <cover.1658698210.git.avityazev@posteo.org>
References: <cover.1658698210.git.avityazev@posteo.org>
From: Aleksandr Vityazev <avityazev@posteo.org>
Date: Sun, 24 Jul 2022 23:05:18 +0300
Subject: [PATCH 22/27] gnu: Add rust-unic-emoji-char-0.9.

* gnu/packages/crates-io.scm (rust-unic-emoji-char-0.9): New variable.
---
gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8eb075ab8f..bb608a5ebb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68142,6 +68142,31 @@ (define-public rust-unic-common-0.9
Internationalization Crates (UNIC) project.")
(license (list license:expat license:asl2.0))))
+(define-public rust-unic-emoji-char-0.9
+ (package
+ (name "rust-unic-emoji-char")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "unic-emoji-char" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-unic-char-property" ,rust-unic-char-property-0.9)
+ ("rust-unic-char-range" ,rust-unic-char-range-0.9)
+ ("rust-unic-ucd-version" ,rust-unic-ucd-version-0.9))))
+ (home-page "https://github.com/open-i18n/rust-unic/")
+ (synopsis "UNIC — Unicode Emoji")
+ (description
+ "This UNIC component implements character properties and algorithms from
+Unicode® Technical Standard #51 - Unicode Emoji.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-unic-segment-0.9
(package
(name "rust-unic-segment")
--
2.37.1
From b7b5118274309e91a9599e487ea3e531a461ce19 Mon Sep 17 00:00:00 2001
Message-Id: <b7b5118274309e91a9599e487ea3e531a461ce19.1658698211.git.avityazev@posteo.org>
In-Reply-To: <cover.1658698210.git.avityazev@posteo.org>
References: <cover.1658698210.git.avityazev@posteo.org>
From: Aleksandr Vityazev <avityazev@posteo.org>
Date: Sun, 24 Jul 2022 23:34:33 +0300
Subject: [PATCH 23/27] gnu: Add rust-textwrap-0.15.

* gnu/packages/crates-io.scm (rust-textwrap-0.15): New variable.
---
gnu/packages/crates-io.scm | 41 ++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bb608a5ebb..f9a11dd408 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -62748,6 +62748,47 @@ (define-public rust-text-size-1
(description "This package provides a newtypes for text offsets")
(license (list license:expat license:asl2.0))))
+(define-public rust-textwrap-0.15
+ (package
+ (name "rust-textwrap")
+ (version "0.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "textwrap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yw513k61lfiwgqrfvsjw1a5wpvm0azhpjr2kr0jhnq9c56is55i"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Cargo.toml"
+ (("version = \"1.5.6\"") "version = \"^1.5.5\""))))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-hyphenation" ,rust-hyphenation-0.8)
+ ("rust-smawk" ,rust-smawk-0.3)
+ ("rust-terminal-size" ,rust-terminal-size-0.1)
+ ("rust-unicode-linebreak" ,rust-unicode-linebreak-0.1)
+ ("rust-unicode-width" ,rust-unicode-width-0.1))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-lipsum" ,rust-lipsum-0.8)
+ ("rust-termion" ,rust-termion-1)
+ ("rust-unic-emoji-char" ,rust-unic-emoji-char-0.9)
+ ("rust-version-sync" ,rust-version-sync-0.9))))
+ (home-page "https://github.com/mgeisler/textwrap")
+ (synopsis "Library for word wrapping, indenting, and dedenting strings")
+ (description
+ "Textwrap is a small library for word wrapping, indenting, and dedenting
+strings. You can use it to format strings (such as help and error messages)
+for display in commandline applications. It is designed to be efficient and
+handle Unicode characters correctly.")
+ (license license:expat)))
+
(define-public rust-textwrap-0.12
(package
(name "rust-textwrap")
--
2.37.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56074@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56074
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch