[gnu: Add dua-cli. 05/27] gnu: Add rust-autocfg-1.1.

  • Open
  • quality assurance status badge
Details
2 participants
  • antlers
  • Maxime Devos
Owner
unassigned
Submitted by
antlers
Severity
normal
Merged with
A
A
antlers wrote on 18 Jun 2022 21:56
20220618195656.10108-6-antlers@luris.net
* gnu/packages/crates-io.scm (rust-autocfg-1.1): New variable.
(rust-autocfg-1): Inherit from rust-autocfg-1.1.
---
:100644 100644 44cb2332dd ca7fe35c0e M gnu/packages/crates-io.scm
gnu/packages/crates-io.scm | 21 ++++++++++++++++++---
1 file changed, 18 insertions(+), 3 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 44cb2332dd..ca7fe35c0e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5227,10 +5227,10 @@ (define-public rust-atty-0.2.11
("rust-termion" ,rust-termion-1)
("rust-winapi" ,rust-winapi-0.3))))))
-(define-public rust-autocfg-1
+(define-public rust-autocfg-1.1
(package
(name "rust-autocfg")
- (version "1.0.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -5239,7 +5239,7 @@ (define-public rust-autocfg-1
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0jj6i9zn4gjl03kjvziqdji6rwx8ykz8zk2ngpc331z2g3fk3c6d"))))
+ "1ylp3cb47ylzabimazvbz9ms6ap784zhb6syaz6c1jqpmcmq0s6l"))))
(build-system cargo-build-system)
(home-page "https://github.com/cuviper/autocfg")
(synopsis
@@ -5248,6 +5248,21 @@ (define-public rust-autocfg-1
"Automatic cfg for Rust compiler features.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-autocfg-1
+ (package
+ (inherit rust-autocfg-1.1)
+ (name "rust-autocfg")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "autocfg" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jj6i9zn4gjl03kjvziqdji6rwx8ykz8zk2ngpc331z2g3fk3c6d"))))))
+
(define-public rust-autocfg-0.1
(package
(inherit rust-autocfg-1)
--
2.36.0
M
M
Maxime Devos wrote on 19 Jun 2022 11:04
Re: [bug#56057] [PATCH 00/27] gnu: Add dua-cli.
(address . control@debbugs.gnu.org)
79b17d35358df25550bf846d732a57044c8436dd.camel@telenet.be
merge 56057 56056 56061 56059 56062 56058 56060 56063 56064 56065 56066 56069 56067 56074 56068 56073 56072 56070 56071 56057
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56058@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56058
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch