[gnu: Add dua-cli. 06/27] gnu: Add rust-parking-lot-0.12.

  • Open
  • quality assurance status badge
Details
2 participants
  • antlers
  • Maxime Devos
Owner
unassigned
Submitted by
antlers
Severity
normal
Merged with
A
A
antlers wrote on 18 Jun 2022 21:56
20220618195656.10108-7-antlers@luris.net
* gnu/packages/crates-io.scm (rust-parking-lot-0.12): New variable.
(rust-parking-lot-0.11): Inherit from rust-parking-lot-0.12.
(rust-parking-lot-0.10): Inherit from rust-parking-lot-0.11.
---
:100644 100644 ca7fe35c0e 22ba059ff5 M gnu/packages/crates-io.scm
gnu/packages/crates-io.scm | 46 +++++++++++++++++++++++++-------------
1 file changed, 30 insertions(+), 16 deletions(-)

Toggle diff (92 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ca7fe35c0e..22ba059ff5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40644,24 +40644,22 @@ (define-public rust-parking-1
(sha256
(base32 "0z6q9rxm98vrp3fimw8b5syzwgf8l0pnn6y0cqm4lbblf7r01cvc"))))))
-(define-public rust-parking-lot-0.11
+(define-public rust-parking-lot-0.12
(package
(name "rust-parking-lot")
- (version "0.11.2")
+ (version "0.12.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "parking_lot" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "16gzf41bxmm10x82bla8d6wfppy9ym3fxsmdjyvn61m66s0bf5vx"))))
+ (base32 "13r2xk7mnxfc5g0g6dkdxqdqad99j7s7z8zhzz4npw5r0g0v4hip"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-instant" ,rust-instant-0.1)
- ("rust-lock-api" ,rust-lock-api-0.4)
- ("rust-parking-lot-core" ,rust-parking-lot-core-0.8))
+ `(#:cargo-inputs
+ (("rust-lock-api" ,rust-lock-api-0.4)
+ ("rust-parking-lot-core" ,rust-parking-lot-core-0.9))
#:cargo-development-inputs
(("rust-bincode" ,rust-bincode-1)
("rust-rand" ,rust-rand-0.8))))
@@ -40673,8 +40671,31 @@ (define-public rust-parking-lot-0.11
of the standard synchronization primitives.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-parking-lot-0.11
+ (package
+ (inherit rust-parking-lot-0.12)
+ (name "rust-parking-lot")
+ (version "0.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "parking_lot" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "16gzf41bxmm10x82bla8d6wfppy9ym3fxsmdjyvn61m66s0bf5vx"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-instant" ,rust-instant-0.1)
+ ("rust-lock-api" ,rust-lock-api-0.4)
+ ("rust-parking-lot-core" ,rust-parking-lot-core-0.8))
+ #:cargo-development-inputs
+ (("rust-bincode" ,rust-bincode-1)
+ ("rust-rand" ,rust-rand-0.8))))))
+
(define-public rust-parking-lot-0.10
(package
+ (inherit rust-parking-lot-0.11)
(name "rust-parking-lot")
(version "0.10.2")
(source
@@ -40685,7 +40706,6 @@ (define-public rust-parking-lot-0.10
(sha256
(base32
"0pjhcbyk6n0g6jsr6s9nf4x8wribm1b2yf8fgc8drbqa77mh99yk"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-lock-api" ,rust-lock-api-0.3)
@@ -40693,13 +40713,7 @@ (define-public rust-parking-lot-0.10
#:cargo-development-inputs
(("rust-bincode" ,rust-bincode-1)
("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-rand" ,rust-rand-0.7))))
- (home-page "https://github.com/Amanieu/parking_lot")
- (synopsis "Compact standard synchronization primitives")
- (description
- "More compact and efficient implementations of the standard
-synchronization primitives.")
- (license (list license:asl2.0 license:expat))))
+ ("rust-rand" ,rust-rand-0.7))))))
(define-public rust-parking-lot-0.9
(package
--
2.36.0
M
M
Maxime Devos wrote on 19 Jun 2022 11:04
Re: [bug#56057] [PATCH 00/27] gnu: Add dua-cli.
(address . control@debbugs.gnu.org)
79b17d35358df25550bf846d732a57044c8436dd.camel@telenet.be
merge 56057 56056 56061 56059 56062 56058 56060 56063 56064 56065 56066 56069 56067 56074 56068 56073 56072 56070 56071 56057
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56060@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56060
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch