[gnu: Add dua-cli. 18/27] gnu: Add rust-simd-adler32-0.3.

  • Open
  • quality assurance status badge
Details
2 participants
  • antlers
  • Maxime Devos
Owner
unassigned
Submitted by
antlers
Severity
normal
Merged with

Debbugs page

antlers wrote 3 years ago
20220618195656.10108-19-antlers@luris.net
* gnu/packages/crates-io.scm (rust-simd-adler32-0.3): New variable.
---
:100644 100644 15dad28f05 1e93172d8e M gnu/packages/crates-io.scm
gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 15dad28f05..1e93172d8e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56608,6 +56608,28 @@ (define-public rust-simd-0.1
#:cargo-development-inputs
(("rust-cfg-if" ,rust-cfg-if-0.1))))))
+(define-public rust-simd-adler32-0.3
+ (package
+ (name "rust-simd-adler32")
+ (version "0.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "simd-adler32" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "060b9v15s3miq06582cj2ywam92ph6xs34s62mc8az3xc4wxz98l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/mcountryman/simd-adler32")
+ (synopsis
+ "SIMD-accelerated Adler-32 rolling hash algorithm implementation")
+ (description
+ "This package provides a SIMD-accelerated Adler-32 rolling hash algorithm
+implementation.")
+ (license license:expat)))
+
(define-public rust-simd-helpers-0.1
(package
(name "rust-simd-helpers")
--
2.36.0
Maxime Devos wrote 3 years ago
Re: [bug#56057] [PATCH 00/27] gnu: Add dua-cli.
(address . control@debbugs.gnu.org)
79b17d35358df25550bf846d732a57044c8436dd.camel@telenet.be
merge 56057 56056 56061 56059 56062 56058 56060 56063 56064 56065 56066 56069 56067 56074 56068 56073 56072 56070 56071 56057
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56071@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56071
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help