[gnu: Add dua-cli. 09/27] gnu: Add rust-crosstemion-0.9.

  • Open
  • quality assurance status badge
Details
2 participants
  • antlers
  • Maxime Devos
Owner
unassigned
Submitted by
antlers
Severity
normal
Merged with
A
A
antlers wrote on 18 Jun 2022 21:56
20220618195656.10108-10-antlers@luris.net
* gnu/packages/crates-io.scm (rust-crosstemion-0.9): New variable.
---
:100644 100644 cf14f1f4dc 0e9c6217f2 M gnu/packages/crates-io.scm
gnu/packages/crates-io.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cf14f1f4dc..0e9c6217f2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14853,6 +14853,38 @@ (define-public rust-crossterm-winapi-0.4
(arguments
`(#:cargo-inputs (("rust-winapi" ,rust-winapi-0.3))))))
+(define-public rust-crosstermion-0.9
+ (package
+ (name "rust-crosstermion")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "crosstermion" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c8rsnqkarw9ly525vwjhjmxn215ipypiya8nx1m7mbfk1dh6pm0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-async-channel" ,rust-async-channel-1)
+ ("rust-crossterm" ,rust-crossterm-0.22)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-termion" ,rust-termion-1)
+ ("rust-tui" ,rust-tui-0.18)
+ ("rust-tui-react" ,rust-tui-react-0.17))))
+ (home-page "https://github.com/Byron/tui-crates")
+ (synopsis
+ "Abstraction of crossterm and termion")
+ (description
+ "The unification of crossterm and termion behind a common facade for use
+with feature flags.")
+ (license license:expat)))
+
(define-public rust-crunchy-0.2
(package
(name "rust-crunchy")
--
2.36.0
M
M
Maxime Devos wrote on 19 Jun 2022 11:04
Re: [bug#56057] [PATCH 00/27] gnu: Add dua-cli.
(address . control@debbugs.gnu.org)
79b17d35358df25550bf846d732a57044c8436dd.camel@telenet.be
merge 56057 56056 56061 56059 56062 56058 56060 56063 56064 56065 56066 56069 56067 56074 56068 56073 56072 56070 56071 56057
thanks
?