[gnu: Add dua-cli. 15/27] gnu: Add rust-open-3.

  • Open
  • quality assurance status badge
Details
2 participants
  • antlers
  • Maxime Devos
Owner
unassigned
Submitted by
antlers
Severity
normal
Merged with

Debbugs page

antlers wrote 3 years ago
20220618195656.10108-16-antlers@luris.net
* gnu/packages/crates-io.scm (rust-open-3): New variable.
(rust-open-2): Inherit from rust-open-3.
---
:100644 100644 926d8cb3f1 308da6fad8 M gnu/packages/crates-io.scm
gnu/packages/crates-io.scm | 35 +++++++++++++++++++++++++++--------
1 file changed, 27 insertions(+), 8 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 926d8cb3f1..308da6fad8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39524,29 +39524,48 @@ (define-public rust-opaque-debug-0.2
(base32
"02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
+(define-public rust-open-3
+ (package
+ (name "rust-open")
+ (version "3.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "open" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zhhz4a9ag0418cmj0ky11xidpcavv2crhsl76m66qxz2s1wq2rn"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-pathdiff" ,rust-pathdiff-0.2)
+ ("rust-windows-sys" ,rust-windows-sys-0.36))))
+ (home-page "https://github.com/Byron/open-rs")
+ (synopsis "Open a path or URL using the program configured on the system")
+ (description
+ "Use this library to open a path or URL using the program configured on
+the system.")
+ (license license:expat)))
+
(define-public rust-open-2
(package
+ (inherit rust-open-3)
(name "rust-open")
(version "2.0.2")
(source
(origin
+ (inherit (package-source rust-open-3))
(method url-fetch)
(uri (crate-uri "open" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1dq9c6dgq7iv5kvqfk8gvkfq34j5pdinfcs1hbdd4x6i62vf8vhp"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
(("rust-pathdiff" ,rust-pathdiff-0.2)
- ("rust-winapi" ,rust-winapi-0.3))))
- (home-page "https://github.com/Byron/open-rs")
- (synopsis "Open a path or URL using the program configured on the system")
- (description
- "Use this library to open a path or URL using the program configured on
-the system.")
- (license license:expat)))
+ ("rust-winapi" ,rust-winapi-0.3))))))
(define-public rust-open-1
(package
--
2.36.0
Maxime Devos wrote 3 years ago
Re: [bug#56057] [PATCH 00/27] gnu: Add dua-cli.
(address . control@debbugs.gnu.org)
79b17d35358df25550bf846d732a57044c8436dd.camel@telenet.be
merge 56057 56056 56061 56059 56062 56058 56060 56063 56064 56065 56066 56069 56067 56074 56068 56073 56072 56070 56071 56057
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56073@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56073
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help