[PATCH 3/9] gnu: Add node-protocol-buffers-schema.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Marius Bakke
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 14 Jun 2022 11:49
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220614094954.15197-3-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-protocol-buffers-schema): New variable.
---
gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index af3745f601..3f49955e29 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -233,6 +233,36 @@ (define-public node-oop
while being as light-weight and simple as possible.")
(license license:expat))))
+(define-public node-protocol-buffers-schema
+ (package
+ (name "node-protocol-buffers-schema")
+ (version "3.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mafintosh/protocol-buffers-schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lnckxj14jzsnfxdd5kmlwrac43c214bv8i2g5rdldymlpxzrz1v"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+ "--offline" "--ignore-scripts" "install" "--production")
+ #t)))))
+ (home-page "https://github.com/mafintosh/protocol-buffers-schema")
+ (synopsis "No nonsense protocol buffers schema parser written in Javascript")
+ (description "This package provides a protocol buffers schema parser written
+in Javascript.")
+ (license license:expat)))
+
(define-public node-stack-trace
;; There have been improvements since the last release.
(let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 15 Jun 2022 11:21
(address . control@debbugs.gnu.org)
c511c7cd5bad5cf933cfee73d92d8253d8b3c9ef.camel@ist.tugraz.at
merge 55958 55959 55960 55961 55962 55963 55964 55965 55966
thanks
M
M
Marius Bakke wrote on 23 Jun 2022 22:25
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
878rpnrusv.fsf@gnu.org
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

Toggle quote (38 lines)
> * gnu/packages/node-xyz.scm (node-protocol-buffers-schema): New variable.
> ---
> gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index af3745f601..3f49955e29 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -233,6 +233,36 @@ (define-public node-oop
> while being as light-weight and simple as possible.")
> (license license:expat))))
>
> +(define-public node-protocol-buffers-schema
> + (package
> + (name "node-protocol-buffers-schema")
> + (version "3.6.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mafintosh/protocol-buffers-schema")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0lnckxj14jzsnfxdd5kmlwrac43c214bv8i2g5rdldymlpxzrz1v"))))
> + (build-system node-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (delete 'check)
> + (replace 'configure
> + (lambda* (#:key inputs #:allow-other-keys)
> + (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> + "--offline" "--ignore-scripts" "install" "--production")
> + #t)))))

Same comments as before regarding arguments and indentation.

Toggle quote (3 lines)
> + (synopsis "No nonsense protocol buffers schema parser written in Javascript")

Avoid marketing words such as "no-nonsense". :-)

Otherwise LGTM.
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYrTMUA8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHdRmAD/SE0vNedfCx2smqbiRQ3uDI5zdMDqdEgiM2L8
vi7CHh0BAK4vQLaW3OtuJfc1XN1rloAWf2EcoZzqatVSRxbZbNkM
=3tiN
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 20 Jul 2022 11:27
[PATCH] gnu: Add node-protocol-buffers-schema.
(address . 55961@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220720092758.12770-1-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-protocol-buffers-schema): New variable.
---
gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index dec7d9ef19..e02a561967 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -232,6 +232,35 @@ (define-public node-oop
while being as light-weight and simple as possible.")
(license license:expat))))
+(define-public node-protocol-buffers-schema
+ (package
+ (name "node-protocol-buffers-schema")
+ (version "3.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mafintosh/protocol-buffers-schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lnckxj14jzsnfxdd5kmlwrac43c214bv8i2g5rdldymlpxzrz1v"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "npm" "--offline"
+ "--ignore-scripts" "install" "--production"))))))
+ (home-page "https://github.com/mafintosh/protocol-buffers-schema")
+ (synopsis "Protocol buffers schema parser written in Javascript")
+ (description "This package provides a protocol buffers schema parser written
+in Javascript.")
+ (license license:expat)))
+
(define-public node-stack-trace
;; There have been improvements since the last release.
(let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")
--
2.37.0
N
N
Nicolas Graves wrote on 20 Jul 2022 11:31
(address . 55961@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220720093115.13280-1-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-protocol-buffers-schema): New variable.
---
gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index dec7d9ef19..4e28224cdf 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -232,6 +232,35 @@ (define-public node-oop
while being as light-weight and simple as possible.")
(license license:expat))))
+(define-public node-protocol-buffers-schema
+ (package
+ (name "node-protocol-buffers-schema")
+ (version "3.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mafintosh/protocol-buffers-schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lnckxj14jzsnfxdd5kmlwrac43c214bv8i2g5rdldymlpxzrz1v"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "npm" "--offline"
+ "--ignore-scripts" "install" "--production"))))))
+ (home-page "https://github.com/mafintosh/protocol-buffers-schema")
+ (synopsis "Protocol buffers schema parser written in Javascript")
+ (description "This package provides a protocol buffers schema parser
+written in Javascript.")
+ (license license:expat)))
+
(define-public node-stack-trace
;; There have been improvements since the last release.
(let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")
--
2.37.0
?