[PATCH 2/9] gnu: Add node-yazl.

  • Done
  • quality assurance status badge
Details
4 participants
  • Liliana Marie Prikler
  • Marius Bakke
  • Maxime Devos
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 14 Jun 2022 11:49
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220614094954.15197-2-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-yazl): New variable.
---
gnu/packages/node-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index be37d627cf..af3745f601 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1335,3 +1335,36 @@ (define-public node-serialport
accessing serial ports. This package is the recommended entry point for most
projects. It combines a high-level Node.js stream interface with a useful
default set of parsers and bindings.")))
+
+(define-public node-yazl
+ (package
+ (name "node-yazl")
+ (version "2.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thejoshwolfe/yazl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lhwqqnvazpi4xw81ldpx0ky0h1j5rcx3br480q2bnzj21cm109n"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+ "--offline" "--ignore-scripts" "install" "--production")
+ #t)))))
+ (inputs (list node-buffer-crc32))
+ (home-page "https://github.com/thejoshwolfe/yazl")
+ (synopsis "Yet another zip library for node")
+ (description "This package provides a zip library for Node. It follows the following principles:
+Don't block the JavaScript thread. Use and provide async APIs.
+Keep memory usage under control. Don't attempt to buffer entire files in RAM at once.
+Prefer to open input files one at a time than all at once. ")
+ (license license:expat)))
--
2.36.1
L
L
Liliana Marie Prikler wrote on 15 Jun 2022 11:21
(address . control@debbugs.gnu.org)
c511c7cd5bad5cf933cfee73d92d8253d8b3c9ef.camel@ist.tugraz.at
merge 55958 55959 55960 55961 55962 55963 55964 55965 55966
thanks
M
M
Marius Bakke wrote on 23 Jun 2022 22:22
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87bkujruxr.fsf@gnu.org
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

Toggle quote (2 lines)
> * gnu/packages/node-xyz.scm (node-yazl): New variable.

[...]

Toggle quote (11 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/thejoshwolfe/yazl")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1lhwqqnvazpi4xw81ldpx0ky0h1j5rcx3br480q2bnzj21cm109n"))))

Indentation seems off here ('./pre-inst-env guix style node-yazl' can
take care of it if you don't use Emacs).

Toggle quote (11 lines)
> + (build-system node-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (delete 'check)
> + (replace 'configure
> + (lambda* (#:key inputs #:allow-other-keys)
> + (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> + "--offline" "--ignore-scripts" "install" "--production")
> + #t)))))

Same comments as previous patch.

Toggle quote (5 lines)
> + (inputs (list node-buffer-crc32))
> + (home-page "https://github.com/thejoshwolfe/yazl")
> + (synopsis "Yet another zip library for node")
> + (description "This package provides a zip library for Node. It follows the following principles:

Keep lines < 78 characters if possible. Also use two spaces after
punctuation.

'./pre-inst-env guix lint PACKAGE' will warn about this and save review
time. ;-)

Toggle quote (4 lines)
> +Don't block the JavaScript thread. Use and provide async APIs.
> +Keep memory usage under control. Don't attempt to buffer entire files in RAM at once.
> +Prefer to open input files one at a time than all at once. ")

Use @enumerate for "bullet lists" which this seems to be.

Otherwise LGTM.
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYrTLoA8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHc7GwD8Dccxstz8chniSO1xghiUjwx/LZL2W8+jKJbp
A708fJ4BALYjbQn9JFPg5w+TQy/dUrFuqtt5kX1a7xwOnM8wK4YD
=4ene
-----END PGP SIGNATURE-----

M
M
Maxime Devos wrote on 24 Jun 2022 00:23
6a52ad42253e0e0c1e9bbacbf1df9802ee51cf21.camel@telenet.be
Nicolas Graves via Guix-patches via schreef op di 14-06-2022 om 11:49
[+0200]:
Toggle quote (2 lines)
> +         (delete 'check)

You can use #:tests? #false for that.

Toggle quote (2 lines)
> + #t)))))

No need for trailing #t anymore (though harmless)!

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrTnxhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7v/2AP0Y5AE+nZW0H5JxQklr6cloWUg7
TB3M82fAmXWNxukZ+wEAwg8CXtsj5SFqyxSKXQmNMaxggA8FiwwYfORjeBPKgQ4=
=4zoy
-----END PGP SIGNATURE-----


N
N
Nicolas Graves wrote on 20 Jul 2022 11:16
[PATCH] gnu: Add node-yazl.
(address . 55964@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220720091601.12006-1-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-yazl): New variable.
---
gnu/packages/node-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index d6035e2c23..dec7d9ef19 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;; Copyright © 2021 Charles <charles.b.jackson@protonmail.com>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1333,3 +1334,39 @@ (define-public node-serialport
accessing serial ports. This package is the recommended entry point for most
projects. It combines a high-level Node.js stream interface with a useful
default set of parsers and bindings.")))
+
+(define-public node-yazl
+ (package
+ (name "node-yazl")
+ (version "2.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thejoshwolfe/yazl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lhwqqnvazpi4xw81ldpx0ky0h1j5rcx3br480q2bnzj21cm109n"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "npm" "--offline"
+ "--ignore-scripts" "install" "--production"))))))
+ (inputs (list node-buffer-crc32))
+ (home-page "https://github.com/thejoshwolfe/yazl")
+ (synopsis "Yet another zip library for node")
+ (description "This package provides a zip library for Node. It follows
+the following principles:
+@enumerate
+@item Don't block the JavaScript thread. Use and provide async APIs.
+@item Keep memory usage under control. Don't attempt to buffer entire
+files in RAM at once.
+@item Prefer to open input files one at a time than all at once.
+@end enumerate")
+ (license license:expat)))
--
2.37.0
?